ArchLinux: 201911-2: qt5-webengine: arbitrary code execution

    Date02 Nov 2019
    CategoryArchLinux
    235
    Posted ByLinuxSecurity Advisories
    Archlinux Large
    The package qt5-webengine before version 5.13.2-2 is vulnerable to arbitrary code execution.
    Arch Linux Security Advisory ASA-201911-2
    =========================================
    
    Severity: Critical
    Date    : 2019-11-02
    CVE-ID  : CVE-2019-13720
    Package : qt5-webengine
    Type    : arbitrary code execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1059
    
    Summary
    =======
    
    The package qt5-webengine before version 5.13.2-2 is vulnerable to
    arbitrary code execution.
    
    Resolution
    ==========
    
    Upgrade to 5.13.2-2.
    
    # pacman -Syu "qt5-webengine>=5.13.2-2"
    
    The problem has been fixed upstream but no release is available yet.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    A use-after-free vulnerability has been found in the audio component of
    the chromium browser before 78.0.3904.87. Google is aware of reports
    that an exploit for this vulnerability exists in the wild.
    
    Impact
    ======
    
    A remote attacker can execute arbitrary code on the affected host.
    
    References
    ==========
    
    https://bugs.archlinux.org/task/64347
    https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=d6e5fc10e417efdf8665d9fba57c269f0534072f
    https://chromereleases.googleblog.com/2019/10/stable-channel-update-for-desktop_31.html
    https://crbug.com/1019226
    https://security.archlinux.org/CVE-2019-13720
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"39","type":"x","order":"1","pct":50.65,"resources":[]},{"id":"88","title":"Should be more technical","votes":"11","type":"x","order":"2","pct":14.29,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"27","type":"x","order":"3","pct":35.06,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.