ArchLinux: 202006-16: tomcat8: denial of service

    Date 30 Jun 2020
    104
    Posted By LinuxSecurity Advisories
    The package tomcat8 before version 8.5.56-1 is vulnerable to denial of service.
    Arch Linux Security Advisory ASA-202006-16
    ==========================================
    
    Severity: Medium
    Date    : 2020-06-28
    CVE-ID  : CVE-2020-11996
    Package : tomcat8
    Type    : denial of service
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1197
    
    Summary
    =======
    
    The package tomcat8 before version 8.5.56-1 is vulnerable to denial of
    service.
    
    Resolution
    ==========
    
    Upgrade to 8.5.56-1.
    
    # pacman -Syu "tomcat8>=8.5.56-1"
    
    The problem has been fixed upstream in version 8.5.56.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    A denial of service has been found in Apache Tomcat before 9.0.36 and
    8.5.56, where a specially crafted sequence of HTTP/2 requests could
    trigger high CPU usage for several seconds. If a sufficient number of
    such requests were made on concurrent HTTP/2 connections, the server
    could become unresponsive.
    
    Impact
    ======
    
    A remote attacker might be able to cause a denial of service via a
    specially crafted sequence of HTTP/2 requests.
    
    References
    ==========
    
    https://www.openwall.com/lists/oss-security/2020/06/25/6
    https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.36
    https://github.com/apache/tomcat/commit/9a0231683a77e2957cea0fdee88b193b30b0c976
    https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.56
    https://github.com/apache/tomcat/commit/c8acd2ab7371e39aeca7c306f3b5380f00afe552
    https://security.archlinux.org/CVE-2020-11996
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"3","type":"x","order":"1","pct":37.5,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"4","type":"x","order":"2","pct":50,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":12.5,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.