Linux Security
    Linux Security
    Linux Security

    ArchLinux: 202010-5: lua: arbitrary code execution

    Date
    121
    Posted By
    The package lua before version 5.4.1-1 is vulnerable to arbitrary code execution.
    Arch Linux Security Advisory ASA-202010-5
    =========================================
    
    Severity: High
    Date    : 2020-10-18
    CVE-ID  : CVE-2020-15888 CVE-2020-15889
    Package : lua
    Type    : arbitrary code execution
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1207
    
    Summary
    =======
    
    The package lua before version 5.4.1-1 is vulnerable to arbitrary code
    execution.
    
    Resolution
    ==========
    
    Upgrade to 5.4.1-1.
    
    # pacman -Syu "lua>=5.4.1-1"
    
    The problems have been fixed upstream in version 5.4.1.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    - CVE-2020-15888 (arbitrary code execution)
    
    Lua through 5.4.0 mishandles the interaction between stack resizes and
    garbage collection, leading to a heap-based buffer overflow, heap-based
    buffer over-read, or use-after-free.
    
    - CVE-2020-15889 (arbitrary code execution)
    
    Lua through 5.4.0 has a getobjname heap-based buffer over-read because
    youngcollection in lgc.c uses markold for an insufficient number of
    list members.
    
    Impact
    ======
    
    A remote attacker is capable of executing arbitrary code on the
    affected host.
    
    References
    ==========
    
    https://lua-users.org/lists/lua-l/2020-07/msg00053.html
    https://lua-users.org/lists/lua-l/2020-07/msg00054.html
    https://lua-users.org/lists/lua-l/2020-07/msg00071.html
    https://lua-users.org/lists/lua-l/2020-07/msg00079.html
    https://github.com/lua/lua/commit/6298903e35217ab69c279056f925fb72900ce0b7
    https://github.com/lua/lua/commit/eb41999461b6f428186c55abd95f4ce1a76217d5
    https://lua-users.org/lists/lua-l/2020-07/msg00078.html
    https://github.com/lua/lua/commit/127e7a6c8942b362aa3c6627f44d660a4fb75312
    https://security.archlinux.org/CVE-2020-15888
    https://security.archlinux.org/CVE-2020-15889
    

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"8","type":"x","order":"1","pct":100,"resources":[]},{"id":"159","title":"False","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.