Arch Linux Security Advisory ASA-202102-21
==========================================

Severity: Low
Date    : 2021-02-07
CVE-ID  : CVE-2021-20216 CVE-2021-20217
Package : privoxy
Type    : denial of service
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1524

Summary
=======

The package privoxy before version 3.0.31-1 is vulnerable to denial of
service.

Resolution
==========

Upgrade to 3.0.31-1.

# pacman -Syu "privoxy>=3.0.31-1"

The problems have been fixed upstream in version 3.0.31.

Workaround
==========

None.

Description
===========

- CVE-2021-20216 (denial of service)

A security issue was found in privoxy before version 3.0.31. A memory
leak when decompression fails unexpectedly may lead to denial of
service.

- CVE-2021-20217 (denial of service)

A security issue was found in privoxy before version 3.0.31. An
assertion failure triggered by a crafted CGI request may lead to denial
of service.

Impact
======

A remote attacker might cause the privoxy server to crash using a
crafted request.

References
==========

https://www.openwall.com/lists/oss-security/2021/01/31/2
https://bugzilla.redhat.com/show_bug.cgi?id=1923256
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commitdiff;h=f431d61740cc03c1c5f6b7f9c7a4a8d0bedd70dd
https://seclists.org/oss-sec/2021/q1/106
https://bugzilla.redhat.com/show_bug.cgi?id=1923252
https://www.privoxy.org/gitweb/?p=privoxy.git;a=commitdiff;h=5bba5b89193fa2eeea51aa39fb6525c47b59a82a
https://security.archlinux.org/CVE-2021-20216
https://security.archlinux.org/CVE-2021-20217