Arch Linux Security Advisory ASA-202102-26
==========================================

Severity: High
Date    : 2021-02-12
CVE-ID  : CVE-2021-26910
Package : firejail
Type    : privilege escalation
Remote  : No
Link    : https://security.archlinux.org/AVG-1545

Summary
=======

The package firejail before version 0.9.64.4-1 is vulnerable to
privilege escalation.

Resolution
==========

Upgrade to 0.9.64.4-1.

# pacman -Syu "firejail>=0.9.64.4-1"

The problem has been fixed upstream in version 0.9.64.4.

Workaround
==========

The issue can be mitigated by setting "overlayfs no" in
/etc/firejail/firejail.config.

Description
===========

Firejail before 0.9.64.4 allows attackers to bypass intended access
restrictions because there is a TOCTOU race condition between a stat
operation and an OverlayFS mount operation.

Impact
======

A local unprivileged attacker can obtain arbitrary file system access
for an application running within a firejail sandbox, leading to
potential privilege escalation.

References
==========

https://unparalleled.eu/publications/2021/advisory-unpar-2021-0.txt
https://unparalleled.eu/blog/2021/20210208-rigged-race-against-firejail-for-local-root/
https://github.com/netblue30/firejail/commit/97d8a03cad19501f017587cc4e47d8418273834b
https://security.archlinux.org/CVE-2021-26910