Arch Linux Security Advisory ASA-202102-31
==========================================

Severity: Medium
Date    : 2021-02-20
CVE-ID  : CVE-2021-3393 CVE-2021-20229
Package : postgresql
Type    : information disclosure
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1567

Summary
=======

The package postgresql before version 13.2-1 is vulnerable to
information disclosure.

Resolution
==========

Upgrade to 13.2-1.

# pacman -Syu "postgresql>=13.2-1"

The problems have been fixed upstream in version 13.2.

Workaround
==========

None.

Description
===========

- CVE-2021-3393 (information disclosure)

A security issue was found in PostgreSQL 11 to 13 before version 13.2.
A user having an UPDATE privilege on a partitioned table but lacking
the SELECT privilege on some column may be able to acquire denied-
column values from an error message. This is similar to CVE-2014-8161,
but the conditions to exploit are more rare.

- CVE-2021-20229 (information disclosure)

A security issue was found in  PostgreSQL 13 before version 13.2. A
user having a SELECT privilege on an individual column can craft a
special query that returns all columns of the table. Additionally, a
stored view that uses column-level privileges will have incomplete
column-usage bitmaps. In installations that depend on column-level
permissions for security, it is recommended to execute CREATE OR
REPLACE on all user-defined views to force them to be re-parsed.

Impact
======

A remote, authenticated user is able to disclose information by
executing crafted SQL queries.

References
==========

https://www.postgresql.org/about/news/postgresql-132-126-1111-1016-9621-and-9525-released-2165/
https://github.com/postgres/postgres/commit/8e56684d54d44ba4ed737d5847d31fba6fb13763
https://github.com/postgres/postgres/commit/d525fbcfd167b28818301d0a2d3548ae6a744588
https://security.archlinux.org/CVE-2021-3393
https://security.archlinux.org/CVE-2021-20229