Arch Linux Security Advisory ASA-202103-18
==========================================

Severity: High
Date    : 2021-03-25
CVE-ID  : CVE-2021-3405
Package : libebml
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1554

Summary
=======

The package libebml before version 1.4.2-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 1.4.2-1.

# pacman -Syu "libebml>=1.4.2-1"

The problem has been fixed upstream in version 1.4.2.

Workaround
==========

None.

Description
===========

A security issue was found in libebml before version 1.4.2. A heap
overflow bug exists in the implementation of EbmlString::ReadData and
EbmlUnicodeString::ReadData in libebml.

Impact
======

A crafted file could execute arbitrary code.

References
==========

https://bugs.archlinux.org/task/70039
https://bugzilla.redhat.com/show_bug.cgi?id=1926990
https://github.com/Matroska-Org/libebml/issues/74
https://github.com/Matroska-Org/libebml/pull/76
https://github.com/Matroska-Org/libebml/commit/3d3d2cff9b012059fa7cb536399b582cc796e04f
https://security.archlinux.org/CVE-2021-3405