Arch Linux Security Advisory ASA-202106-10
==========================================

Severity: High
Date    : 2021-06-01
CVE-ID  : CVE-2021-25217
Package : dhclient
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2004

Summary
=======

The package dhclient before version 4.4.2.P1-1 is vulnerable to
arbitrary code execution.

Resolution
==========

Upgrade to 4.4.2.P1-1.

# pacman -Syu "dhclient>=4.4.2.P1-1"

The problem has been fixed upstream in version 4.4.2.P1.

Workaround
==========

None.

Description
===========

A buffer overrun in the lease file parsing code can be used to exploit
a common vulnerability shared by dhcpd and dhclient before version
4.4.2-P1.

Impact
======

An attacker could crash the DHCP client, or potentially execute
arbitrary code, through a crafted lease file.

References
==========

https://kb.isc.org/docs/cve-2021-25217
https://downloads.isc.org/isc/dhcp/4.4.2-P1/patches/4.4.2.CVE-2021-25217.patch
https://security.archlinux.org/CVE-2021-25217