ArchLinux: 202106-31: chromium: multiple issues | LinuxSecurity.com

Advisories

Arch Linux Security Advisory ASA-202106-31
==========================================

Severity: Critical
Date    : 2021-06-15
CVE-ID  : CVE-2021-30544 CVE-2021-30545 CVE-2021-30546 CVE-2021-30547
          CVE-2021-30548 CVE-2021-30549 CVE-2021-30550 CVE-2021-30551
          CVE-2021-30552 CVE-2021-30553
Package : chromium
Type    : multiple issues
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2057

Summary
=======

The package chromium before version 91.0.4472.101-1 is vulnerable to
multiple issues including arbitrary code execution and incorrect
calculation.

Resolution
==========

Upgrade to 91.0.4472.101-1.

# pacman -Syu "chromium>=91.0.4472.101-1"

The problems have been fixed upstream in version 91.0.4472.101.

Workaround
==========

None.

Description
===========

- CVE-2021-30544 (arbitrary code execution)

A use after free security issue has been found in the BFCache component
of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30545 (arbitrary code execution)

A use after free security issue has been found in the Extensions
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30546 (arbitrary code execution)

A use after free security issue has been found in the Autofill
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30547 (arbitrary code execution)

An out of bounds write security issue has been found in the ANGLE
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30548 (arbitrary code execution)

A use after free security issue has been found in the Loader component
of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30549 (arbitrary code execution)

A use after free security issue has been found in the Spell check
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30550 (arbitrary code execution)

A use after free security issue has been found in the Accessibility
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30551 (incorrect calculation)

A type confusion security issue has been found in the V8 component of
the Chromium browser before version 91.0.4472.101. Google is aware that
an exploit for CVE-2021-30551 exists in the wild.

- CVE-2021-30552 (arbitrary code execution)

A use after free security issue has been found in the Extensions
component of the Chromium browser before version 91.0.4472.101.

- CVE-2021-30553 (arbitrary code execution)

A use after free security issue has been found in the Network service
component of the Chromium browser before version 91.0.4472.101.

Impact
======

A remote attacker could execute arbitrary code through a crafted web
page or extension. Google is aware that an exploit for one of the
security issues exists in the wild.

References
==========

https://chromereleases.googleblog.com/2021/06/stable-channel-update-for-desktop.html
https://crbug.com/1212618
https://crbug.com/1201031
https://crbug.com/1206911
https://crbug.com/1210414
https://crbug.com/1210487
https://crbug.com/1212498
https://crbug.com/1212500
https://crbug.com/1216437
https://crbug.com/1200679
https://crbug.com/1209769
https://security.archlinux.org/CVE-2021-30544
https://security.archlinux.org/CVE-2021-30545
https://security.archlinux.org/CVE-2021-30546
https://security.archlinux.org/CVE-2021-30547
https://security.archlinux.org/CVE-2021-30548
https://security.archlinux.org/CVE-2021-30549
https://security.archlinux.org/CVE-2021-30550
https://security.archlinux.org/CVE-2021-30551
https://security.archlinux.org/CVE-2021-30552
https://security.archlinux.org/CVE-2021-30553

ArchLinux: 202106-31: chromium: multiple issues

June 17, 2021
The package chromium before version 91.0.4472.101-1 is vulnerable to multiple issues including arbitrary code execution and incorrect calculation

Summary

- CVE-2021-30544 (arbitrary code execution)
A use after free security issue has been found in the BFCache component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30545 (arbitrary code execution)
A use after free security issue has been found in the Extensions component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30546 (arbitrary code execution)
A use after free security issue has been found in the Autofill component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30547 (arbitrary code execution)
An out of bounds write security issue has been found in the ANGLE component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30548 (arbitrary code execution)
A use after free security issue has been found in the Loader component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30549 (arbitrary code execution)
A use after free security issue has been found in the Spell check component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30550 (arbitrary code execution)
A use after free security issue has been found in the Accessibility component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30551 (incorrect calculation)
A type confusion security issue has been found in the V8 component of the Chromium browser before version 91.0.4472.101. Google is aware that an exploit for CVE-2021-30551 exists in the wild.
- CVE-2021-30552 (arbitrary code execution)
A use after free security issue has been found in the Extensions component of the Chromium browser before version 91.0.4472.101.
- CVE-2021-30553 (arbitrary code execution)
A use after free security issue has been found in the Network service component of the Chromium browser before version 91.0.4472.101.

Resolution

Upgrade to 91.0.4472.101-1.
# pacman -Syu "chromium>=91.0.4472.101-1"
The problems have been fixed upstream in version 91.0.4472.101.

References

https://chromereleases.googleblog.com/2021/06/stable-channel-update-for-desktop.html https://crbug.com/1212618 https://crbug.com/1201031 https://crbug.com/1206911 https://crbug.com/1210414 https://crbug.com/1210487 https://crbug.com/1212498 https://crbug.com/1212500 https://crbug.com/1216437 https://crbug.com/1200679 https://crbug.com/1209769 https://security.archlinux.org/CVE-2021-30544 https://security.archlinux.org/CVE-2021-30545 https://security.archlinux.org/CVE-2021-30546 https://security.archlinux.org/CVE-2021-30547 https://security.archlinux.org/CVE-2021-30548 https://security.archlinux.org/CVE-2021-30549 https://security.archlinux.org/CVE-2021-30550 https://security.archlinux.org/CVE-2021-30551 https://security.archlinux.org/CVE-2021-30552 https://security.archlinux.org/CVE-2021-30553

Severity
CVE-ID : CVE-2021-30544 CVE-2021-30545 CVE-2021-30546 CVE-2021-30547
CVE-2021-30548 CVE-2021-30549 CVE-2021-30550 CVE-2021-30551
CVE-2021-30552 CVE-2021-30553
Package : chromium
Type : multiple issues
Remote : Yes
Link : https://security.archlinux.org/AVG-2057

Impact

A remote attacker could execute arbitrary code through a crafted web page or extension. Google is aware that an exploit for one of the security issues exists in the wild.

Workaround

None.

Related News

© 2022 Guardian Digital, Inc All Rights Reserved

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.