Arch Linux Security Advisory ASA-202106-53
==========================================

Severity: Medium
Date    : 2021-06-22
CVE-ID  : CVE-2020-35509
Package : keycloak
Type    : certificate verification bypass
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2084

Summary
=======

The package keycloak before version 14.0.0-1 is vulnerable to
certificate verification bypass.

Resolution
==========

Upgrade to 14.0.0-1.

# pacman -Syu "keycloak>=14.0.0-1"

The problem has been fixed upstream in version 14.0.0.

Workaround
==========

None.

Description
===========

A security issue has been found in Keycloak before version 14.0.0.
Depending on the webserver configuration, a malicious user can supply
an expired certificate and it would be accepted by Keycloak direct-
grant authenticator. This is because Keycloak does not trigger the
appropriate timestamp validation.

Impact
======

A user could authenticate with an expired certificate.

References
==========

https://bugzilla.redhat.com/show_bug.cgi?id=1912427
https://issues.redhat.com/browse/KEYCLOAK-16450
https://github.com/keycloak/keycloak/pull/8067
https://github.com/keycloak/keycloak/commit/478319348bdfdb9b6d39122f41edf2af79f679bb
https://security.archlinux.org/CVE-2020-35509