Arch Linux Security Advisory ASA-202106-44
==========================================

Severity: High
Date    : 2021-06-16
CVE-ID  : CVE-2021-33833
Package : connman
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2055

Summary
=======

The package connman before version 1.40-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 1.40-1.

# pacman -Syu "connman>=1.40-1"

The problem has been fixed upstream in version 1.40.

Workaround
==========

None.

Description
===========

A security issue has been found in the dnsproxy component of connman in
releases 1.32 to 1.39. Unpacking of NAME and RDATA/RDLENGTH fields with
TYPE A/AAAA in the uncompress function uses a memcpy with insufficient
bounds checking, which can overflow a stack buffer.

Impact
======

A remote attacker might be able to execute arbitrary code on the
victim's host.

References
==========

https://www.openwall.com/lists/oss-security/2021/06/09/1
https://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=eceb2e8d2341c041df55a5e2f047d9a8c491463c
https://security.archlinux.org/CVE-2021-33833