Arch Linux Security Advisory ASA-202106-8
=========================================

Severity: Medium
Date    : 2021-06-01
CVE-ID  : CVE-2021-22898
Package : libcurl-gnutls
Type    : information disclosure
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1999

Summary
=======

The package libcurl-gnutls before version 7.77.0-1 is vulnerable to
information disclosure.

Resolution
==========

Upgrade to 7.77.0-1.

# pacman -Syu "libcurl-gnutls>=7.77.0-1"

The problem has been fixed upstream in version 7.77.0.

Workaround
==========

The issue can be mitigated by avoiding to use the -t command line
option and CURLOPT_TELNETOPTIONS.

Description
===========

A security issue has been found in curl before version 7.77.0. curl
supports the -t command line option, known as CURLOPT_TELNETOPTIONS in
libcurl. This rarely used option is used to send variable=content pairs
to TELNET servers. Due to flaw in the option parser for sending NEW_ENV
variables, libcurl could be made to pass on uninitialized data from a
stack based buffer to the server. Therefore potentially revealing
sensitive internal information to the server using a clear-text network
protocol.

Impact
======

curl could disclose potentially sensitive memory information to a
remote server over Telnet when an uncommon option is used.

References
==========

https://curl.se/docs/CVE-2021-22898.html
https://github.com/curl/curl/commit/39ce47f219b09c380b81f89fe54ac586c8db6bde
https://security.archlinux.org/CVE-2021-22898