Arch Linux Security Advisory ASA-202107-71
==========================================

Severity: Medium
Date    : 2021-07-27
CVE-ID  : CVE-2020-15660
Package : geckodriver
Type    : cross-site request forgery
Remote  : Yes
Link    : https://security.archlinux.org/AVG-2180

Summary
=======

The package geckodriver before version 0.29.1-1 is vulnerable to cross-
site request forgery.

Resolution
==========

Upgrade to 0.29.1-1.

# pacman -Syu "geckodriver>=0.29.1-1"

The problem has been fixed upstream in version 0.29.1.

Workaround
==========

None.

Description
===========

Missing checks on Content-Type headers in geckodriver before 0.27.0
could lead to a cross-site request forgery (CSRF) vulnerability, that
might, when paired with a specifically prepared request, lead to remote
code execution.

Impact
======

A remote attacker could execute arbitrary code through a crafted
request.

References
==========

https://bugs.archlinux.org/task/71558
https://github.com/mozilla/geckodriver/releases/tag/v0.27.0
https://security.archlinux.org/CVE-2020-15660