- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2564-1              [email protected]
https://www.debian.org/lts/security/                    Sylvain Beucler
February 18, 2021                           https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : php-horde-text-filter
Version        : 2.3.5-1+deb9u1
CVE ID         : CVE-2021-26929
Debian Bug     : 982769

Alex Birnberg discovered a cross-site scripting (XSS) vulnerability in
the Horde Application Framework, more precisely its Text Filter API.
An attacker could take control of a user's mailbox by sending a
crafted e-mail.

CVE-2021-26929

    An XSS issue was discovered in Horde Groupware Webmail Edition
    (where the Horde_Text_Filter library is used). The attacker can
    send a plain text e-mail message, with JavaScript encoded as a
    link or email that is mishandled by preProcess in Text2html.php,
    because bespoke use of \x00\x00\x00 and \x01\x01\x01 interferes
    with XSS defenses.

For Debian 9 stretch, this problem has been fixed in version
2.3.5-1+deb9u1.

We recommend that you upgrade your php-horde-text-filter packages.

For the detailed security status of php-horde-text-filter please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/php-horde-text-filter

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS