- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2585-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
March 08, 2021                              https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : libupnp
Version        : 1:1.6.19+git20160116-1.2+deb9u1
CVE ID         : CVE-2020-13848
Debian Bug     : 962282

libupnp, the portable SDK for UPnP Devices allows remote attackers to
cause a denial of service (crash) via a crafted SSDP message due to a
NULL pointer dereference in the functions FindServiceControlURLPath
and FindServiceEventURLPath in genlib/service_table/service_table.c.

For Debian 9 stretch, this problem has been fixed in version
1:1.6.19+git20160116-1.2+deb9u1.

We recommend that you upgrade your libupnp packages.

For the detailed security status of libupnp please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libupnp

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS