Debian LTS: DLA-2700-1: htmldoc security update | LinuxSecurity.com

Advisories


- -----------------------------------------------------------------------
Debian LTS Advisory DLA-2700-1              [email protected]
https://www.debian.org/lts/security/                      Utkarsh Gupta
July 01, 2021                               https://wiki.debian.org/LTS
- -----------------------------------------------------------------------

Package        : htmldoc
Version        : 1.8.27-8+deb9u1
CVE ID         : CVE-2019-19630 CVE-2021-20308 CVE-2021-23158
                 CVE-2021-23165 CVE-2021-23180 CVE-2021-23191
                 CVE-2021-23206 CVE-2021-26252 CVE-2021-26259
                 CVE-2021-26948

A buffer overflow was discovered in HTMLDOC, a HTML processor that
generates indexed HTML, PS, and PDF, which could potentially result
in the execution of arbitrary code. In addition a number of crashes
were addressed.

For Debian 9 stretch, these problems have been fixed in version
1.8.27-8+deb9u1.

We recommend that you upgrade your htmldoc packages.

For the detailed security status of htmldoc please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/htmldoc

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-2700-1: htmldoc security update

July 1, 2021
A buffer overflow was discovered in HTMLDOC, a HTML processor that generates indexed HTML, PS, and PDF, which could potentially result in the execution of arbitrary code

Summary

For Debian 9 stretch, these problems have been fixed in version
1.8.27-8+deb9u1.

We recommend that you upgrade your htmldoc packages.

For the detailed security status of htmldoc please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/htmldoc

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : htmldoc
Version : 1.8.27-8+deb9u1
CVE ID : CVE-2019-19630 CVE-2021-20308 CVE-2021-23158

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.