Debian LTS: DLA-3086-1: maven-shared-utils security update | LinuxS...
-------------------------------------------------------------------------
Debian LTS Advisory DLA-3086-1                [email protected]
https://www.debian.org/lts/security/                      Markus Koschany
August 29, 2022                               https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : maven-shared-utils
Version        : 3.3.0-1+deb10u1
CVE ID         : CVE-2022-29599
Debian Bug     : 1012314

It was discovered that the Commandline class in maven-shared-utils, a
collection of various utility classes for the Maven build system, can emit
double-quoted strings without proper escaping, allowing shell injection
attacks.

For Debian 10 buster, this problem has been fixed in version
3.3.0-1+deb10u1.

We recommend that you upgrade your maven-shared-utils packages.

For the detailed security status of maven-shared-utils please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/maven-shared-utils

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3086-1: maven-shared-utils security update

August 29, 2022
It was discovered that the Commandline class in maven-shared-utils, a collection of various utility classes for the Maven build system, can emit double-quoted strings without prope...

Summary


It was discovered that the Commandline class in maven-shared-utils, a
collection of various utility classes for the Maven build system, can emit
double-quoted strings without proper escaping, allowing shell injection
attacks.

For Debian 10 buster, this problem has been fixed in version
3.3.0-1+deb10u1.

We recommend that you upgrade your maven-shared-utils packages.

For the detailed security status of maven-shared-utils please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/maven-shared-utils

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : maven-shared-utils
Version : 3.3.0-1+deb10u1
CVE ID : CVE-2022-29599
Debian Bug : 1012314

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.