Discover Government News

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200408-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PuTTY: Pre-authentication arbitrary code execution
      Date: August 05, 2004
      Bugs: #59383
        ID: 200408-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
PuTTY contains a vulnerability allowing a SSH server to execute
arbitrary code on the connecting client.

Background
=========
PuTTY is a free implementation of Telnet and SSH for Win32 and Unix
platforms, along with an xterm terminal emulator.

Affected packages
================
    -------------------------------------------------------------------
     Package         /   Vulnerable   /                     Unaffected
    -------------------------------------------------------------------
  1  net-misc/putty        <= 0.54                             >= 0.55

Description
==========
PuTTY contains a vulnerability allowing a malicious server to execute
arbitrary code on the connecting client before host key verification.

Impact
=====
When connecting to a server using the SSH2 protocol an attacker is able
to execute arbitrary code with the permissions of the user running
PuTTY by sending specially crafted packets to the client during the
authentication process but before host key verification.

Workaround
=========
There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of PuTTY.

Resolution
=========
All PuTTY users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=net-misc/putty-0.55"
    # emerge ">=net-misc/putty-0.55"

References
=========
  [ 1 ] PuTTY ChangeLog
        https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    https://security.gentoo.org/glsa/200408-04

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/1.0/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBEiNpzKC5hMHO6rkRAqqfAKCAlxPnzBfJ396cnyBBeWsMi+sQKwCfRlP2
MVDuAX5vjBz5sMu1sCBvI6A=sog4
-----END PGP SIGNATURE-----

Gentoo: GLSA-200408-04: PuTTY: Pre-authentication arbitrary code execution

PuTTY contains a vulnerability allowing a SSH server to execute arbitrary code on the connecting client.

Summary

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Gentoo Linux Security Advisory                           GLSA 200408-04
                                            https://security.gentoo.org/

Severity: Normal Title: PuTTY: Pre-authentication arbitrary code execution Date: August 05, 2004 Bugs: #59383 ID: 200408-04

Synopsis ======= PuTTY contains a vulnerability allowing a SSH server to execute arbitrary code on the connecting client.
Background ========= PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms, along with an xterm terminal emulator.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-misc/putty <= 0.54 >= 0.55
========== PuTTY contains a vulnerability allowing a malicious server to execute arbitrary code on the connecting client before host key verification.
Impact ===== When connecting to a server using the SSH2 protocol an attacker is able to execute arbitrary code with the permissions of the user running PuTTY by sending specially crafted packets to the client during the authentication process but before host key verification.
Workaround ========= There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of PuTTY.
Resolution ========= All PuTTY users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=net-misc/putty-0.55" # emerge ">=net-misc/putty-0.55"
References ========= [ 1 ] PuTTY ChangeLog https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200408-04
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/1.0/ -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.4 (GNU/Linux)
iD8DBQFBEiNpzKC5hMHO6rkRAqqfAKCAlxPnzBfJ396cnyBBeWsMi+sQKwCfRlP2 MVDuAX5vjBz5sMu1sCBvI6A=sog4 -----END PGP SIGNATURE-----

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News