Gentoo: GLSA-200408-07: Horde-IMP: Input validation vulnerability for Internet Explorer users

    Date 10 Aug 2004
    87
    Posted By LinuxSecurity Advisories
    An input validation vulnerability has been discovered in Horde-IMP. This only affects users of Internet Explorer.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 200408-07
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
      Severity: Normal
         Title: Horde-IMP: Input validation vulnerability for Internet
                Explorer users
          Date: August 10, 2004
          Bugs: #59336
            ID: 200408-07
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    An input validation vulnerability has been discovered in Horde-IMP.
    This only affects users of Internet Explorer.
    
    Background
    ==========
    
    Horde-IMP is the Internet Messaging Program. It is written in PHP and
    provides webmail access to IMAP and POP3 accounts.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package            /   Vulnerable   /                  Unaffected
        -------------------------------------------------------------------
      1  net-www/horde-imp       <= 3.2.4                         >= 3.2.5
    
    Description
    ===========
    
    Horde-IMP fails to properly sanitize email messages that contain
    malicious HTML or script code so that it is not safe for users of
    Internet Explorer when using the inline MIME viewer for HTML messages.
    
    Impact
    ======
    
    By enticing a user to read a specially crafted e-mail, an attacker can
    execute arbitrary scripts running in the context of the victim's
    browser. This could lead to a compromise of the user's webmail account,
    cookie theft, etc.
    
    Workaround
    ==========
    
    Do not use Internet Explorer to access Horde-IMP.
    
    Resolution
    ==========
    
    All Horde-IMP users should upgrade to the latest stable version:
    
        # emerge sync
    
        # emerge -pv ">=horde-imp-3.2.5"
        # emerge ">=horde-imp-3.2.5"
    
    References
    ==========
    
      [ 1 ] Horde-IMP Changelog
            https://cvs.horde.org/diff.php/imp/docs/CHANGES?r1=1.389.2.106&r2=1.389.2.109&ty=h
      [ 2 ] Secunia Advisory SA12202
            https://secunia.com/advisories/12202/
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
        https://security.gentoo.org/glsa/glsa-200408-07.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/1.0
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"2","type":"x","order":"1","pct":40,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"2","type":"x","order":"2","pct":40,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.