Gentoo: GLSA-201411-04: PHP: Multiple vulnerabilities

    Date 09 Nov 2014
    83
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been discovered in PHP, the worst of which could lead to remote execution of arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201411-04
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: PHP: Multiple vulnerabilities
         Date: November 09, 2014
         Bugs: #525960
           ID: 201411-04
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been discovered in PHP, the worst of
    which could lead to remote execution of arbitrary code.
    
    Background
    ==========
    
    PHP is a widely-used general-purpose scripting language that is
    especially suited for Web development and can be embedded into HTML.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-lang/php                 < 5.5.18                  >= 5.5.18
                                                               *>= 5.4.34
                                                               *>= 5.3.29
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in PHP. Please review the
    CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A context-dependent attacker can possibly execute arbitrary code or
    create a Denial of Service condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All PHP 5.5 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.5.18"
    
    All PHP 5.4 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.4.34"
    
    All PHP 5.3 users should upgrade to the latest version. This release
    marks the end of life of the PHP 5.3 series. Future releases of this
    series are not planned. All PHP 5.3 users are encouraged to upgrade to
    the current stable version of PHP 5.5 or previous stable version of PHP
    5.4, which are supported till at least 2016 and 2015 respectively.
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.3.29"
    
    References
    ==========
    
    [ 1 ] CVE-2014-3668
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3668
    [ 2 ] CVE-2014-3669
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3669
    [ 3 ] CVE-2014-3670
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3670
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/glsa-201411-04.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    

    LinuxSecurity Poll

    Do you feel that the Lawful Access to Encrypted Data Act, which aims to force encryption backdoors, is a threat to US citizens' privacy?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/30-do-you-feel-that-the-lawful-access-to-encrypted-data-act-which-aims-to-force-encryption-backdoors-is-a-threat-to-privacy?task=poll.vote&format=json
    30
    radio
    [{"id":"106","title":"Yes - I am a privacy advocate and I am strongly opposed to this bill.","votes":"23","type":"x","order":"1","pct":95.83,"resources":[]},{"id":"107","title":"I'm undecided - it has its pros and cons.","votes":"1","type":"x","order":"2","pct":4.17,"resources":[]},{"id":"108","title":"No - I support this bill and feel that it will help protect against crime and threats to our national security. ","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.