Gentoo: GLSA-201406-34: KDE Libraries: Multiple vulnerabilities

    Date 29 Jun 2014
    86
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been discovered in KDE Libraries, the worst of which could lead to man-in-the-middle attacks.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201406-34
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: KDE Libraries: Multiple vulnerabilities
         Date: June 29, 2014
         Bugs: #358025, #384227, #469140, #513726
           ID: 201406-34
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been discovered in KDE Libraries, the
    worst of which could lead to man-in-the-middle attacks.
    
    Background
    ==========
    
    KDE is a feature-rich graphical desktop environment for Linux and
    Unix-like operating systems. KDE Libraries contains libraries needed by
    all KDE applications.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  kde-base/kdelibs           < 4.12.5-r1              >= 4.12.5-r1 
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in KDE Libraries. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker could cause a man-in-the-middle attack via any 
    certificate issued by a legitimate certification authority.
    Furthermore, a local attacker may gain knowledge of user passwords
    through an information leak.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All KDE users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-4.12.5-r1"
    
    References
    ==========
    
    [ 1 ] CVE-2011-1094
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1094
    [ 2 ] CVE-2011-3365
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3365
    [ 3 ] CVE-2013-2074
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2074
    [ 4 ] CVE-2014-3494
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3494
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/glsa-201406-34.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    

    LinuxSecurity Poll

    Do you feel that the Lawful Access to Encrypted Data Act, which aims to force encryption backdoors, is a threat to US citizens' privacy?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/30-do-you-feel-that-the-lawful-access-to-encrypted-data-act-which-aims-to-force-encryption-backdoors-is-a-threat-to-privacy?task=poll.vote&format=json
    30
    radio
    [{"id":"106","title":"Yes - I am a privacy advocate and I am strongly opposed to this bill.","votes":"19","type":"x","order":"1","pct":95,"resources":[]},{"id":"107","title":"I'm undecided - it has its pros and cons.","votes":"1","type":"x","order":"2","pct":5,"resources":[]},{"id":"108","title":"No - I support this bill and feel that it will help protect against crime and threats to our national security. ","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.