Gentoo: GLSA-200408-03: libpng: Numerous vulnerabilities

    Date05 Aug 2004
    CategoryGentoo
    67
    Posted ByLinuxSecurity Advisories
    libpng contains numerous vulnerabilities potentially allowing an attacker to perform a Denial of Service attack or even execute arbitrary code. [More...]
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 200408-03
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
      Severity: Normal
         Title: libpng: Numerous vulnerabilities
          Date: August 05, 2004
          Bugs: #59424
            ID: 200408-03
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    libpng contains numerous vulnerabilities potentially allowing an
    attacker to perform a Denial of Service attack or even execute
    arbitrary code.
    
    Background
    ==========
    
    libpng is a standard library used to process PNG (Portable Network
    Graphics) images. It is used by several other programs, including web
    browsers and potentially server processes.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package            /   Vulnerable   /                  Unaffected
        -------------------------------------------------------------------
      1  media-libs/libpng      <= 1.2.5-r7                    >= 1.2.5-r8
    
    Description
    ===========
    
    libpng contains numerous vulnerabilities including null pointer
    dereference errors and boundary errors in various functions.
    
    Impact
    ======
    
    An attacker could exploit these vulnerabilities to cause programs
    linked against the library to crash or execute arbitrary code with the
    permissions of the user running the vulnerable program, which could be
    the root user.
    
    Workaround
    ==========
    
    There is no known workaround at this time. All users are encouraged to
    upgrade to the latest available version.
    
    Resolution
    ==========
    
    All libpng users should upgrade to the latest stable version:
    
        # emerge sync
    
        # emerge -pv ">=media-libs/libpng-1.2.5-r8"
        # emerge ">=media-libs/libpng-1.2.5-r8"
    
    You should also run revdep-rebuild to rebuild any packages that depend
    on older versions of libpng :
    
        # revdep-rebuild
    
    References
    ==========
    
      [ 1 ] CAN-2004-0597
            http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0597
      [ 2 ] CAN-2004-0598
            http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0598
      [ 3 ] CAN-2004-0599
            http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0599
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
        http://security.gentoo.org/glsa/glsa-200408-03.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    http://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/1.0
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)
    
    iD8DBQFBEiDEzKC5hMHO6rkRArWQAJ9tGcHpudcqkfWyvi041+B9ticNDwCff+6c
    gV6Jd15qu3lxxWneLJn1Ev4=
    =WtCw
    -----END PGP SIGNATURE-----
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"67","type":"x","order":"1","pct":57.26,"resources":[]},{"id":"88","title":"Should be more technical","votes":"16","type":"x","order":"2","pct":13.68,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"34","type":"x","order":"3","pct":29.06,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.