Gentoo: GLSA-201409-10: Bash: Code Injection (Updated fix for GLSA 201409-09)

    Date25 Sep 2014
    CategoryGentoo
    36
    Posted ByLinuxSecurity Advisories
    A parsing flaw related to functions and environments in Bash could allow attackers to inject code. The unaffected packages listed in GLSA 201409-09 had an incomplete fix. [More...]
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201409-10
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: High
        Title: Bash: Code Injection (Updated fix for GLSA 201409-09)
         Date: September 25, 2014
         Bugs: #523592
           ID: 201409-10
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    A parsing flaw related to functions and environments in Bash could
    allow attackers to inject code. The unaffected packages listed in GLSA
    201409-09 had an incomplete fix.
    
    Background
    ==========
    
    Bash is the standard GNU Bourne Again SHell.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  app-shells/bash            < 4.2_p48-r1 *>= 3.1_p18-r1
                                                           *>= 3.2_p52-r1
                                                           *>= 4.0_p39-r1
                                                           *>= 4.1_p12-r1
                                                            >= 4.2_p48-r1
    
    Description
    ===========
    
    Stephane Chazelas reported that Bash incorrectly handles function
    definitions, allowing attackers to inject arbitrary code
    (CVE-2014-6271). Gentoo Linux informed about this issue in GLSA
    201409-09.
    
    Tavis Ormandy reported that the patch for CVE-2014-6271 was incomplete.
    As such, this GLSA supersedes GLSA 201409-09.
    
    Impact
    ======
    
    A remote attacker could exploit this vulnerability to execute arbitrary
    commands even in restricted environments.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All Bash 3.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.1_p18-r1"
    
    All Bash 3.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.2_p52-r1"
    
    All Bash 4.0 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.0_p39-r1"
    
    All Bash 4.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.1_p12-r1"
    
    All Bash 4.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.2_p48-r1"
    
    References
    ==========
    
    [ 1 ] CVE-2014-7169
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-7169
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201409-10.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"5","type":"x","order":"1","pct":55.56,"resources":[]},{"id":"88","title":"Should be more technical","votes":"3","type":"x","order":"2","pct":33.33,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":11.11,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.