Gentoo: GLSA-201410-01: Bash: Multiple vulnerabilities

    Date04 Oct 2014
    CategoryGentoo
    51
    Posted ByLinuxSecurity Advisories
    Multiple parsing flaws in Bash could allow remote attackers to inject code or cause a Denial of Service condition.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201410-01
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: High
        Title: Bash: Multiple vulnerabilities
         Date: October 04, 2014
         Bugs: #523742, #524256
           ID: 201410-01
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple parsing flaws in Bash could allow remote attackers to inject
    code or cause a Denial of Service condition.
    
    Background
    ==========
    
    Bash is the standard GNU Bourne Again SHell.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  app-shells/bash             < 4.2_p52                *>= 3.1_p22
                                                              *>= 3.2_p56
                                                              *>= 4.0_p43
                                                              *>= 4.1_p16
                                                               >= 4.2_p52
    
    Description
    ===========
    
    Florian Weimer, Todd Sabin, Michal Zalewski et al. discovered further
    parsing flaws in Bash. The unaffected Gentoo packages listed in this
    GLSA contain the official patches to fix the issues tracked as
    CVE-2014-6277, CVE-2014-7186, and CVE-2014-7187. Furthermore, the
    official patch known as "function prefix patch" is included which
    prevents the exploitation of CVE-2014-6278.
    
    Impact
    ======
    
    A remote attacker could exploit these vulnerabilities to execute
    arbitrary commands or cause a Denial of Service condition via various
    vectors.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All Bash 3.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.1_p22:3.1"
    
    All Bash 3.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-3.2_p56:3.2"
    
    All Bash 4.0 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.0_p43:4.0"
    
    All Bash 4.1 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.1_p16:4.1"
    
    All Bash 4.2 users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=app-shells/bash-4.2_p52"
    
    References
    ==========
    
    [ 1 ] CVE-2014-6277
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6277
    [ 2 ] CVE-2014-6278
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6278
    [ 3 ] CVE-2014-7186
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-7186
    [ 4 ] CVE-2014-7187
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-7187
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201410-01.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"40","type":"x","order":"1","pct":48.78,"resources":[]},{"id":"88","title":"Should be more technical","votes":"13","type":"x","order":"2","pct":15.85,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"29","type":"x","order":"3","pct":35.37,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.