Gentoo: GLSA-201410-02: Perl, Perl Locale-Maketext module: Multiple vulnerabilities

    Date12 Oct 2014
    CategoryGentoo
    39
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in Perl Locale-Maketext module, allowing remote attackers to inject and execute arbitrary Perl code. [More...]
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201410-02
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: Perl, Perl Locale-Maketext module: Multiple vulnerabilities
         Date: October 12, 2014
         Bugs: #446376
           ID: 201410-02
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in Perl Locale-Maketext
    module, allowing remote attackers to inject and execute arbitrary Perl
    code.
    
    Background
    ==========
    
    Locale-Maketext - Perl framework for localization
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  perl-core/Locale-Maketext
                                     < 1.230.0 >= 1.230.0 
      2  dev-lang/perl                < 5.17.7 >= 5.17.7 
        -------------------------------------------------------------------
         2 affected packages
    
    Description
    ===========
    
    Two vulnerabilities have been reported in Locale-Maketext module for
    Perl, which can be exploited
    by malicious users to compromise an application using the module.
    
    The vulnerabilities are caused due to the "_compile()" function not
    properly sanitising input,
    which can be exploited to inject and execute arbitrary Perl code.
    
    Impact
    ======
    
    A remote attacker could possibly execute
    arbitrary code with the privileges of the process, or cause a Denial of
    Service condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All users of the Perl Locale-Maketext module should upgrade to the
    latest version:
    
      # emerge --sync
      # emerge --ask --oneshot -v ">=perl-core/locale-maketext-1.230.0"
    
    References
    ==========
    
    [ 1 ] CVE-2012-6329
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-6329
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201410-02.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"4","type":"x","order":"1","pct":57.14,"resources":[]},{"id":"88","title":"Should be more technical","votes":"2","type":"x","order":"2","pct":28.57,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":14.29,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.