Gentoo: GLSA-202003-59: libvpx: User-assisted execution of arbitrary code

    Date26 Mar 2020
    193
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in libvpx, the worst of which could result in the execution of arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202003-59
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: libvpx: User-assisted execution of arbitrary code
         Date: March 26, 2020
         Bugs: #701834
           ID: 202003-59
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in libvpx, the worst of which
    could result in the execution of arbitrary code.
    
    Background
    ==========
    
    libvpx is the VP8 codec SDK used to encode and decode video streams,
    typically within a WebM format media file.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  media-libs/libvpx            < 1.8.1                *>= 1.7.0-r1
                                                                *>= 1.8.1
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in libvpx. Please review
    the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker could entice a user to open a specially crafted media
    file, possibly resulting in the execution of arbitrary code with the
    privileges of the user running the application, or a Denial of Service.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All libvpx 1.7.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.7.0-r1"
    
    All libvpx 1.8.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/libvpx-1.8.1"
    
    References
    ==========
    
    [ 1 ] CVE-2019-9232
          https://nvd.nist.gov/vuln/detail/CVE-2019-9232
    [ 2 ] CVE-2019-9325
          https://nvd.nist.gov/vuln/detail/CVE-2019-9325
    [ 3 ] CVE-2019-9371
          https://nvd.nist.gov/vuln/detail/CVE-2019-9371
    [ 4 ] CVE-2019-9433
          https://nvd.nist.gov/vuln/detail/CVE-2019-9433
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202003-59
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    

    LinuxSecurity Poll

    What do you think of the LinuxSecurity Privacy news articles?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/25-what-do-you-think-of-the-linuxsecurity-privacy-news-articles?task=poll.vote&format=json
    25
    radio
    [{"id":"90","title":"Love them!","votes":"48","type":"x","order":"1","pct":88.89,"resources":[]},{"id":"91","title":"I'm indifferent","votes":"4","type":"x","order":"2","pct":7.41,"resources":[]},{"id":"92","title":"Not interested in this topic","votes":"2","type":"x","order":"3","pct":3.7,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.