Gentoo: GLSA-202003-60: QtCore: Multiple vulnerabilities

    Date 26 Mar 2020
    248
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in QtCore, the worst of which could result in the execution of arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 202003-60
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                               https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: QtCore: Multiple vulnerabilities
         Date: March 26, 2020
         Bugs: #699226, #707354
           ID: 202003-60
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in QtCore, the worst of which
    could result in the execution of arbitrary code.
    
    Background
    ==========
    
    The Qt toolkit is a comprehensive C++ application development
    framework.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-qt/qtcore              < 5.13.2-r2             *>= 5.12.3-r2
                                                            *>= 5.13.2-r2
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in QtCore. Please review
    the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    An attacker could possibly execute arbitrary code with the privileges
    of the process or cause a Denial of Service condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All QtCore 5.12.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.12.3-r2"
    
    All QtCore 5.13.x users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.13.2-r2"
    
    References
    ==========
    
    [ 1 ] CVE-2019-18281
          https://nvd.nist.gov/vuln/detail/CVE-2019-18281
    [ 2 ] CVE-2020-0569
          https://nvd.nist.gov/vuln/detail/CVE-2020-0569
    [ 3 ] CVE-2020-0570
          https://nvd.nist.gov/vuln/detail/CVE-2020-0570
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/202003-60
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2020 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"3","type":"x","order":"1","pct":42.86,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"3","type":"x","order":"2","pct":42.86,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":14.29,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.