Gentoo: GLSA-202104-04: Python: Multiple vulnerabilities | LinuxSec...

Advisories

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202104-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Python: Multiple vulnerabilities
      Date: April 30, 2021
      Bugs: #770853, #779841, #779844
        ID: 202104-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Python, the worst of which
might allow attackers to access sensitive information.

Background
==========

Python is an interpreted, interactive, object-oriented programming
language.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  dev-lang/python             < 3.9.2_p1          >= 2.7.18_p8:2.7
                                                      >= 3.6.13_p1:3.6
                                                      >= 3.7.10_p1:3.7
                                                       >= 3.8.8_p1:3.8
                                                       >= 3.9.2_p1:3.9

Description
===========

Multiple vulnerabilities have been discovered in Python. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Python 2.7 users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.18_p8"

All Python 3.6 users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/python-3.6.13_p1"

All Python 3.7 users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/python-3.7.10_p1"

All Python 3.8 users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/python-3.8.8_p1"

All Python 3.9 users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-lang/python-3.9.2_p1"

References
==========

[ 1 ] CVE-2021-23336
       https://nvd.nist.gov/vuln/detail/CVE-2021-23336
[ 2 ] CVE-2021-3426
       https://nvd.nist.gov/vuln/detail/CVE-2021-3426

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202104-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202104-04: Python: Multiple vulnerabilities

Summary

Multiple vulnerabilities have been discovered in Python. Please review the CVE identifiers referenced below for details.

Resolution

All Python 2.7 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-2.7.18_p8"
All Python 3.6 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.6.13_p1"
All Python 3.7 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.7.10_p1"
All Python 3.8 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.8.8_p1"
All Python 3.9 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/python-3.9.2_p1"

References

[ 1 ] CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336 [ 2 ] CVE-2021-3426 https://nvd.nist.gov/vuln/detail/CVE-2021-3426

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202104-04

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Python: Multiple vulnerabilities
Issued Date: April 30, 2021
Bugs: #770853, #779841, #779844
ID: 202104-04

Synopsis

Multiple vulnerabilities have been found in Python, the worst of which might allow attackers to access sensitive information.

Background

Python is an interpreted, interactive, object-oriented programming language.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-lang/python < 3.9.2_p1 >= 2.7.18_p8:2.7 >= 3.6.13_p1:3.6 >= 3.7.10_p1:3.7 >= 3.8.8_p1:3.8 >= 3.9.2_p1:3.9

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.