- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202104-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Mozilla Firefox: Multiple vulnerabilities
      Date: April 30, 2021
      Bugs: #772305, #778269, #784572
        ID: 202104-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Mozilla Firefox, the worst
of which could result in the arbitrary execution of code.

Background
==========

Mozilla Firefox is a popular open-source web browser from the Mozilla
project.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  www-client/firefox            < 88.0          >= 78.10.0:0/esr78
                                                               >= 88.0
   2  www-client/firefox-bin        < 88.0          >= 78.10.0:0/esr78
                                                               >= 88.0
     -------------------------------------------------------------------
      2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in Mozilla Firefox.
Please review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Mozilla Firefox ESR users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-client/firefox-78.10.0"

All Mozilla Firefox ESR binary users should upgrade to the latest
version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-78.10.0"

All Mozilla Firefox users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-client/firefox-88.0"

All Mozilla Firefox binary users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=www-client/firefox-bin-88.0"

References
==========

[  1 ] CVE-2021-23961
        https://nvd.nist.gov/vuln/detail/CVE-2021-23961
[  2 ] CVE-2021-23968
        https://nvd.nist.gov/vuln/detail/CVE-2021-23968
[  3 ] CVE-2021-23969
        https://nvd.nist.gov/vuln/detail/CVE-2021-23969
[  4 ] CVE-2021-23970
        https://nvd.nist.gov/vuln/detail/CVE-2021-23970
[  5 ] CVE-2021-23971
        https://nvd.nist.gov/vuln/detail/CVE-2021-23971
[  6 ] CVE-2021-23972
        https://nvd.nist.gov/vuln/detail/CVE-2021-23972
[  7 ] CVE-2021-23973
        https://nvd.nist.gov/vuln/detail/CVE-2021-23973
[  8 ] CVE-2021-23974
        https://nvd.nist.gov/vuln/detail/CVE-2021-23974
[  9 ] CVE-2021-23975
        https://nvd.nist.gov/vuln/detail/CVE-2021-23975
[ 10 ] CVE-2021-23976
        https://nvd.nist.gov/vuln/detail/CVE-2021-23976
[ 11 ] CVE-2021-23977
        https://nvd.nist.gov/vuln/detail/CVE-2021-23977
[ 12 ] CVE-2021-23978
        https://nvd.nist.gov/vuln/detail/CVE-2021-23978
[ 13 ] CVE-2021-23981
        https://nvd.nist.gov/vuln/detail/CVE-2021-23981
[ 14 ] CVE-2021-23982
        https://nvd.nist.gov/vuln/detail/CVE-2021-23982
[ 15 ] CVE-2021-23983
        https://nvd.nist.gov/vuln/detail/CVE-2021-23983
[ 16 ] CVE-2021-23984
        https://nvd.nist.gov/vuln/detail/CVE-2021-23984
[ 17 ] CVE-2021-23985
        https://nvd.nist.gov/vuln/detail/CVE-2021-23985
[ 18 ] CVE-2021-23986
        https://nvd.nist.gov/vuln/detail/CVE-2021-23986
[ 19 ] CVE-2021-23987
        https://nvd.nist.gov/vuln/detail/CVE-2021-23987
[ 20 ] CVE-2021-23988
        https://nvd.nist.gov/vuln/detail/CVE-2021-23988
[ 21 ] CVE-2021-23994
        https://nvd.nist.gov/vuln/detail/CVE-2021-23994
[ 22 ] CVE-2021-23995
        https://nvd.nist.gov/vuln/detail/CVE-2021-23995
[ 23 ] CVE-2021-23998
        https://nvd.nist.gov/vuln/detail/CVE-2021-23998
[ 24 ] CVE-2021-23999
        https://nvd.nist.gov/vuln/detail/CVE-2021-23999
[ 25 ] CVE-2021-24002
        https://nvd.nist.gov/vuln/detail/CVE-2021-24002
[ 26 ] CVE-2021-29945
        https://nvd.nist.gov/vuln/detail/CVE-2021-29945
[ 27 ] CVE-2021-29946
        https://nvd.nist.gov/vuln/detail/CVE-2021-29946
[ 28 ] MFSA-2021-08
        https://www.mozilla.org/en-US/security/advisories/mfsa2021-08/
[ 29 ] MFSA-2021-11
        https://www.mozilla.org/en-US/security/advisories/mfsa2021-11/
[ 30 ] MFSA-2021-15
        https://www.mozilla.org/en-US/security/advisories/mfsa2021-15/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202104-10

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5