Gentoo: GLSA-202210-37: PJSIP: Multiple Vulnerabilities | LinuxSecu...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202210-37
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: PJSIP: Multiple Vulnerabilities
     Date: October 31, 2022
     Bugs: #803614, #829894, #875863
       ID: 202210-37

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PJSIP, the worst of which
could result in arbitrary code execution.

Background
==========

PJSIP is a free and open source multimedia communication library written
in C language implementing standard based protocols such as SIP, SDP,
RTP, STUN, TURN, and ICE.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-libs/pjproject         < 2.12.1                    >= 2.12.1

Description
===========

Multiple vulnerabilities have been discovered in PJSIP. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PJSIP users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/pjproject-2.12.1"

References
==========

[ 1 ] CVE-2021-32686
      https://nvd.nist.gov/vuln/detail/CVE-2021-32686
[ 2 ] CVE-2021-37706
      https://nvd.nist.gov/vuln/detail/CVE-2021-37706
[ 3 ] CVE-2021-41141
      https://nvd.nist.gov/vuln/detail/CVE-2021-41141
[ 4 ] CVE-2021-43804
      https://nvd.nist.gov/vuln/detail/CVE-2021-43804
[ 5 ] CVE-2021-43845
      https://nvd.nist.gov/vuln/detail/CVE-2021-43845
[ 6 ] CVE-2022-21722
      https://nvd.nist.gov/vuln/detail/CVE-2022-21722
[ 7 ] CVE-2022-21723
      https://nvd.nist.gov/vuln/detail/CVE-2022-21723
[ 8 ] CVE-2022-23608
      https://nvd.nist.gov/vuln/detail/CVE-2022-23608
[ 9 ] CVE-2022-24754
      https://nvd.nist.gov/vuln/detail/CVE-2022-24754
[ 10 ] CVE-2022-24763
      https://nvd.nist.gov/vuln/detail/CVE-2022-24763
[ 11 ] CVE-2022-24764
      https://nvd.nist.gov/vuln/detail/CVE-2022-24764
[ 12 ] CVE-2022-24786
      https://nvd.nist.gov/vuln/detail/CVE-2022-24786
[ 13 ] CVE-2022-24792
      https://nvd.nist.gov/vuln/detail/CVE-2022-24792
[ 14 ] CVE-2022-24793
      https://nvd.nist.gov/vuln/detail/CVE-2022-24793
[ 15 ] CVE-2022-31031
      https://nvd.nist.gov/vuln/detail/CVE-2022-31031
[ 16 ] CVE-2022-39244
      https://nvd.nist.gov/vuln/detail/CVE-2022-39244
[ 17 ] CVE-2022-39269
      https://nvd.nist.gov/vuln/detail/CVE-2022-39269

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202210-37

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202210-37: PJSIP: Multiple Vulnerabilities

Summary

Multiple vulnerabilities have been discovered in PJSIP. Please review the CVE identifiers referenced below for details.

Resolution

All PJSIP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-libs/pjproject-2.12.1"

References

[ 1 ] CVE-2021-32686 https://nvd.nist.gov/vuln/detail/CVE-2021-32686 [ 2 ] CVE-2021-37706 https://nvd.nist.gov/vuln/detail/CVE-2021-37706 [ 3 ] CVE-2021-41141 https://nvd.nist.gov/vuln/detail/CVE-2021-41141 [ 4 ] CVE-2021-43804 https://nvd.nist.gov/vuln/detail/CVE-2021-43804 [ 5 ] CVE-2021-43845 https://nvd.nist.gov/vuln/detail/CVE-2021-43845 [ 6 ] CVE-2022-21722 https://nvd.nist.gov/vuln/detail/CVE-2022-21722 [ 7 ] CVE-2022-21723 https://nvd.nist.gov/vuln/detail/CVE-2022-21723 [ 8 ] CVE-2022-23608 https://nvd.nist.gov/vuln/detail/CVE-2022-23608 [ 9 ] CVE-2022-24754 https://nvd.nist.gov/vuln/detail/CVE-2022-24754 [ 10 ] CVE-2022-24763 https://nvd.nist.gov/vuln/detail/CVE-2022-24763 [ 11 ] CVE-2022-24764 https://nvd.nist.gov/vuln/detail/CVE-2022-24764 [ 12 ] CVE-2022-24786 https://nvd.nist.gov/vuln/detail/CVE-2022-24786 [ 13 ] CVE-2022-24792 https://nvd.nist.gov/vuln/detail/CVE-2022-24792 [ 14 ] CVE-2022-24793 https://nvd.nist.gov/vuln/detail/CVE-2022-24793 [ 15 ] CVE-2022-31031 https://nvd.nist.gov/vuln/detail/CVE-2022-31031 [ 16 ] CVE-2022-39244 https://nvd.nist.gov/vuln/detail/CVE-2022-39244 [ 17 ] CVE-2022-39269 https://nvd.nist.gov/vuln/detail/CVE-2022-39269

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202210-37

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: PJSIP: Multiple Vulnerabilities
Date: October 31, 2022
Bugs: #803614, #829894, #875863
ID: 202210-37

Synopsis

Multiple vulnerabilities have been found in PJSIP, the worst of which could result in arbitrary code execution.

Background

PJSIP is a free and open source multimedia communication library written in C language implementing standard based protocols such as SIP, SDP, RTP, STUN, TURN, and ICE.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-libs/pjproject < 2.12.1 >= 2.12.1

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.