Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202210-38
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Low
    Title: Expat: Denial of Service
     Date: October 31, 2022
     Bugs: #878271
       ID: 202210-38

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability has been found in Expat which could result in denial of
service.

Background
=========
Expat is a set of XML parsing libraries.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-libs/expat             < 2.5.0                      >= 2.5.0

Description
==========
In certain out-of-memory situations, Expat may free memory before it
should, leading to a use-after-free.

Impact
=====
A use-after-free can result in denial of service.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Expat users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/expat-2.5.0"

References
=========
[ 1 ] CVE-2022-43680
      https://nvd.nist.gov/vuln/detail/CVE-2022-43680

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202210-38

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-202210-38: Expat: Denial of Service

A vulnerability has been found in Expat which could result in denial of service.

Summary

In certain out-of-memory situations, Expat may free memory before it should, leading to a use-after-free.

Resolution

All Expat users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/expat-2.5.0"

References

[ 1 ] CVE-2022-43680 https://nvd.nist.gov/vuln/detail/CVE-2022-43680

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/202210-38

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Low
Title: Expat: Denial of Service
Date: October 31, 2022
Bugs: #878271
ID: 202210-38

Synopsis

A vulnerability has been found in Expat which could result in denial of service.

Background

Expat is a set of XML parsing libraries.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-libs/expat < 2.5.0 >= 2.5.0

Impact

===== A use-after-free can result in denial of service.

Workaround

There is no known workaround at this time.

Related News