MGASA-2021-0449 - Updated libgd packages fix security vulnerability

Publication date: 29 Sep 2021
URL: https://advisories.mageia.org/MGASA-2021-0449.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-40812

The updated packages fix a security vulnerability:

The GD Graphics Library (aka LibGD) through 2.3.2 has an out-of-bounds
read because of the lack of certain gdGetBuf and gdPutBuf return value
checks (CVE-2021-40812).

References:
- https://bugs.mageia.org/show_bug.cgi?id=29486
- https://lists.opensuse.org/archives/list/[email protected]/thread/FCVD7RYV2TSOLINPDAIY7P7Q4OSCOREN/
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-40812

SRPMS:
- 8/core/libgd-2.3.1-1.3.mga8