Discover Mobile Security News

   openSUSE Security Update: Security update for postgresql10
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2020:2019-1
Rating:             important
References:         #1178666 #1178667 #1178668 
Cross-References:   CVE-2020-25694 CVE-2020-25695 CVE-2020-25696
                   
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for postgresql10 fixes the following issues:

   - Upgrade to version 10.15:
     * CVE-2020-25695, bsc#1178666: Block DECLARE CURSOR ... WITH HOLD and
       firing of deferred triggers within index expressions and materialized
       view queries.
     * CVE-2020-25694, bsc#1178667: a) Fix usage of complex connection-string
       parameters in pg_dump, pg_restore, clusterdb, reindexdb, and vacuumdb.
       b) When psql's \connect command re-uses connection parameters, ensure
       that all non-overridden parameters from a previous connection string
       are re-used.
     * CVE-2020-25696, bsc#1178668: Prevent psql's \gset command from
       modifying specially-treated variables.
     * Fix recently-added timetz test case so it works when the USA is not
       observing daylight savings time.
     * https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/
     * https://www.postgresql.org/docs/10/release-10-15.html

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2020-2019=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      postgresql10-10.15-lp152.2.9.1
      postgresql10-contrib-10.15-lp152.2.9.1
      postgresql10-contrib-debuginfo-10.15-lp152.2.9.1
      postgresql10-debuginfo-10.15-lp152.2.9.1
      postgresql10-debugsource-10.15-lp152.2.9.1
      postgresql10-devel-10.15-lp152.2.9.1
      postgresql10-devel-debuginfo-10.15-lp152.2.9.1
      postgresql10-plperl-10.15-lp152.2.9.1
      postgresql10-plperl-debuginfo-10.15-lp152.2.9.1
      postgresql10-plpython-10.15-lp152.2.9.1
      postgresql10-plpython-debuginfo-10.15-lp152.2.9.1
      postgresql10-pltcl-10.15-lp152.2.9.1
      postgresql10-pltcl-debuginfo-10.15-lp152.2.9.1
      postgresql10-server-10.15-lp152.2.9.1
      postgresql10-server-debuginfo-10.15-lp152.2.9.1
      postgresql10-test-10.15-lp152.2.9.1

   - openSUSE Leap 15.2 (noarch):

      postgresql10-docs-10.15-lp152.2.9.1


References:

   https://www.suse.com/security/cve/CVE-2020-25694.html
   https://www.suse.com/security/cve/CVE-2020-25695.html
   https://www.suse.com/security/cve/CVE-2020-25696.html
   https://bugzilla.suse.com/1178666
   https://bugzilla.suse.com/1178667
   https://bugzilla.suse.com/1178668
_______________________________________________
openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org
To unsubscribe, email security-announce-leave@lists.opensuse.org
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/

openSUSE: 2020:2019-1 important: postgresql10

November 25, 2020
An update that fixes three vulnerabilities is now available.

Description

This update for postgresql10 fixes the following issues: - Upgrade to version 10.15: * CVE-2020-25695, bsc#1178666: Block DECLARE CURSOR ... WITH HOLD and firing of deferred triggers within index expressions and materialized view queries. * CVE-2020-25694, bsc#1178667: a) Fix usage of complex connection-string parameters in pg_dump, pg_restore, clusterdb, reindexdb, and vacuumdb. b) When psql's \connect command re-uses connection parameters, ensure that all non-overridden parameters from a previous connection string are re-used. * CVE-2020-25696, bsc#1178668: Prevent psql's \gset command from modifying specially-treated variables. * Fix recently-added timetz test case so it works when the USA is not observing daylight savings time. * https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/ * https://www.postgresql.org/docs/10/release-10-15.html This update was imported from the SUSE:SLE-15-SP1:Update update project.

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.2: zypper in -t patch openSUSE-2020-2019=1


Package List

- openSUSE Leap 15.2 (i586 x86_64): postgresql10-10.15-lp152.2.9.1 postgresql10-contrib-10.15-lp152.2.9.1 postgresql10-contrib-debuginfo-10.15-lp152.2.9.1 postgresql10-debuginfo-10.15-lp152.2.9.1 postgresql10-debugsource-10.15-lp152.2.9.1 postgresql10-devel-10.15-lp152.2.9.1 postgresql10-devel-debuginfo-10.15-lp152.2.9.1 postgresql10-plperl-10.15-lp152.2.9.1 postgresql10-plperl-debuginfo-10.15-lp152.2.9.1 postgresql10-plpython-10.15-lp152.2.9.1 postgresql10-plpython-debuginfo-10.15-lp152.2.9.1 postgresql10-pltcl-10.15-lp152.2.9.1 postgresql10-pltcl-debuginfo-10.15-lp152.2.9.1 postgresql10-server-10.15-lp152.2.9.1 postgresql10-server-debuginfo-10.15-lp152.2.9.1 postgresql10-test-10.15-lp152.2.9.1 - openSUSE Leap 15.2 (noarch): postgresql10-docs-10.15-lp152.2.9.1


References

https://www.suse.com/security/cve/CVE-2020-25694.html https://www.suse.com/security/cve/CVE-2020-25695.html https://www.suse.com/security/cve/CVE-2020-25696.html https://bugzilla.suse.com/1178666 https://bugzilla.suse.com/1178667 https://bugzilla.suse.com/1178668 openSUSE Security Announce mailing list -- security-announce@lists.opensuse.org To unsubscribe, email security-announce-leave@lists.opensuse.org List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette List Archives: https://lists.opensuse.org/archives/list/security-announce@lists.opensuse.org/


Severity
Announcement ID: openSUSE-SU-2020:2019-1
Rating: important
Affected Products: openSUSE Leap 15.2

Related News