openSUSE Security Update: Security update for go1.15
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1207-1
Rating:             moderate
References:         #1175132 #1188906 #1189162 
Cross-References:   CVE-2021-36221
Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that solves one vulnerability and has two fixes
   is now available.

Description:

   This update for go1.15 fixes the following issues:

   Update to go1.15.15:

   - go#47473 net/https: panic due to racy read of persistConn after handler
     panic (CVE-2021-36221 bsc#1189162)
   - go#47347 cmd/go: "go list -f '{{.Stale}}'" stack overflow with cyclic
     imports
   - go#47014 cmd/go: go mod vendor: open C:\Users\LICENSE: Access is denied.
   - go#46927 cmd/compile: register conflict between external linker and
     duffzero on arm64
   - go#46857 runtime: ppc64x binaries randomly segfault on linux 5.13rc6

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1207=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      go1.15-1.15.15-lp152.26.1
      go1.15-doc-1.15.15-lp152.26.1
      go1.15-race-1.15.15-lp152.26.1


References:

   https://www.suse.com/security/cve/CVE-2021-36221.html
   https://bugzilla.suse.com/1175132
   https://bugzilla.suse.com/1188906
   https://bugzilla.suse.com/1189162