openSUSE Security Update: Security update for apache2
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1438-1
Rating:             important
References:         #1190666 #1190669 #1190702 #1190703 
Cross-References:   CVE-2021-34798 CVE-2021-36160 CVE-2021-39275
                    CVE-2021-40438
CVSS scores:
                    CVE-2021-34798 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-36160 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-39275 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-40438 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for apache2 fixes the following issues:

   - CVE-2021-40438: Fixed a SRF via a crafted request uri-path. (bsc#1190703)
   - CVE-2021-36160: Fixed an out-of-bounds read via a crafted request
     uri-path. (bsc#1190702)
   - CVE-2021-39275: Fixed an out-of-bounds write in ap_escape_quotes() via
     malicious input. (bsc#1190666)
   - CVE-2021-34798: Fixed a NULL pointer dereference via malformed requests.
     (bsc#1190669)

   This update was imported from the SUSE:SLE-15-SP2:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1438=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      apache2-2.4.43-lp152.2.21.1
      apache2-debuginfo-2.4.43-lp152.2.21.1
      apache2-debugsource-2.4.43-lp152.2.21.1
      apache2-devel-2.4.43-lp152.2.21.1
      apache2-event-2.4.43-lp152.2.21.1
      apache2-event-debuginfo-2.4.43-lp152.2.21.1
      apache2-example-pages-2.4.43-lp152.2.21.1
      apache2-prefork-2.4.43-lp152.2.21.1
      apache2-prefork-debuginfo-2.4.43-lp152.2.21.1
      apache2-utils-2.4.43-lp152.2.21.1
      apache2-utils-debuginfo-2.4.43-lp152.2.21.1
      apache2-worker-2.4.43-lp152.2.21.1
      apache2-worker-debuginfo-2.4.43-lp152.2.21.1

   - openSUSE Leap 15.2 (noarch):

      apache2-doc-2.4.43-lp152.2.21.1


References:

   https://www.suse.com/security/cve/CVE-2021-34798.html
   https://www.suse.com/security/cve/CVE-2021-36160.html
   https://www.suse.com/security/cve/CVE-2021-39275.html
   https://www.suse.com/security/cve/CVE-2021-40438.html
   https://bugzilla.suse.com/1190666
   https://bugzilla.suse.com/1190669
   https://bugzilla.suse.com/1190702
   https://bugzilla.suse.com/1190703