openSUSE Security Update: Security update for qemu
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3604-1
Rating:             important
References:         #1189234 #1189702 #1189938 #1190425 
Cross-References:   CVE-2021-3713 CVE-2021-3748
CVSS scores:
                    CVE-2021-3713 (SUSE): 7.8 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
                    CVE-2021-3748 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves two vulnerabilities and has two fixes
   is now available.

Description:

   This update for qemu fixes the following issues:

   Security issues fixed:

   - CVE-2021-3713: Fix out-of-bounds write in UAS (USB Attached SCSI) device
     emulation (bsc#1189702)
   - CVE-2021-3748: Fix heap use-after-free in virtio_net_receive_rcu
     (bsc#1189938)

   Non-security issues fixed:

   - Add transfer length item in block limits page of scsi vpd (bsc#1190425)
   - Fix qemu crash while deleting xen-block (bsc#1189234)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3604=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      qemu-s390-4.2.1-11.31.3
      qemu-s390-debuginfo-4.2.1-11.31.3


References:

   https://www.suse.com/security/cve/CVE-2021-3713.html
   https://www.suse.com/security/cve/CVE-2021-3748.html
   https://bugzilla.suse.com/1189234
   https://bugzilla.suse.com/1189702
   https://bugzilla.suse.com/1189938
   https://bugzilla.suse.com/1190425