openSUSE Security Update: Security update for apache-commons-compress
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:2612-1
Rating:             important
References:         #1188463 #1188464 #1188465 #1188466 
Cross-References:   CVE-2021-35515 CVE-2021-35516 CVE-2021-35517
                    CVE-2021-36090
CVSS scores:
                    CVE-2021-35515 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-35515 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-35516 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-35517 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-36090 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-36090 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for apache-commons-compress fixes the following issues:

   - Updated to 1.21
   - CVE-2021-35515: Fixed an infinite loop when reading a specially crafted
     7Z archive. (bsc#1188463)
   - CVE-2021-35516: Fixed an excessive memory allocation when reading a
     specially crafted 7Z archive. (bsc#1188464)
   - CVE-2021-35517: Fixed an excessive memory allocation when reading a
     specially crafted TAR archive. (bsc#1188465)
   - CVE-2021-36090: Fixed an excessive memory allocation when reading a
     specially crafted ZIP archive. (bsc#1188466)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-2612=1



Package List:

   - openSUSE Leap 15.3 (noarch):

      apache-commons-compress-1.21-3.3.1
      apache-commons-compress-javadoc-1.21-3.3.1


References:

   https://www.suse.com/security/cve/CVE-2021-35515.html
   https://www.suse.com/security/cve/CVE-2021-35516.html
   https://www.suse.com/security/cve/CVE-2021-35517.html
   https://www.suse.com/security/cve/CVE-2021-36090.html
   https://bugzilla.suse.com/1188463
   https://bugzilla.suse.com/1188464
   https://bugzilla.suse.com/1188465
   https://bugzilla.suse.com/1188466