openSUSE: 2021:3255-1 moderate: postgresql13 | LinuxSecurity.com

Advisories


   openSUSE Security Update: Security update for postgresql13
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3255-1
Rating:             moderate
References:         #1179945 #1185952 #1187751 #1189748 
Cross-References:   CVE-2021-3677
CVSS scores:
                    CVE-2021-3677 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves one vulnerability and has three fixes
   is now available.

Description:

   This update for postgresql13 fixes the following issues:

   - CVE-2021-3677: Fixed memory disclosure in certain queries (bsc#1189748).

   - Fixed build with llvm12 on s390x (bsc#1185952).
   - Re-enabled icu for PostgreSQL 10 (bsc#1179945).
   - Made the dependency of postgresqlXX-server-devel on llvm and clang
     optional (bsc#1187751).
   - llvm12 breaks PostgreSQL 11 and 12 on s390x. Use llvm11 as a workaround
     (bsc#1185952).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3255=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libecpg6-13.4-5.16.2
      libecpg6-debuginfo-13.4-5.16.2
      libpq5-13.4-5.16.2
      libpq5-debuginfo-13.4-5.16.2
      postgresql13-13.4-5.16.2
      postgresql13-contrib-13.4-5.16.2
      postgresql13-contrib-debuginfo-13.4-5.16.2
      postgresql13-debuginfo-13.4-5.16.2
      postgresql13-debugsource-13.4-5.16.1
      postgresql13-debugsource-13.4-5.16.2
      postgresql13-devel-13.4-5.16.2
      postgresql13-devel-debuginfo-13.4-5.16.2
      postgresql13-llvmjit-13.4-5.16.2
      postgresql13-llvmjit-debuginfo-13.4-5.16.2
      postgresql13-plperl-13.4-5.16.2
      postgresql13-plperl-debuginfo-13.4-5.16.2
      postgresql13-plpython-13.4-5.16.2
      postgresql13-plpython-debuginfo-13.4-5.16.2
      postgresql13-pltcl-13.4-5.16.2
      postgresql13-pltcl-debuginfo-13.4-5.16.2
      postgresql13-server-13.4-5.16.2
      postgresql13-server-debuginfo-13.4-5.16.2
      postgresql13-server-devel-13.4-5.16.2
      postgresql13-server-devel-debuginfo-13.4-5.16.2
      postgresql13-test-13.4-5.16.2

   - openSUSE Leap 15.3 (noarch):

      postgresql13-docs-13.4-5.16.2

   - openSUSE Leap 15.3 (x86_64):

      libecpg6-32bit-13.4-5.16.2
      libecpg6-32bit-debuginfo-13.4-5.16.2
      libpq5-32bit-13.4-5.16.2
      libpq5-32bit-debuginfo-13.4-5.16.2


References:

   https://www.suse.com/security/cve/CVE-2021-3677.html
   https://bugzilla.suse.com/1179945
   https://bugzilla.suse.com/1185952
   https://bugzilla.suse.com/1187751
   https://bugzilla.suse.com/1189748

openSUSE: 2021:3255-1 moderate: postgresql13

September 29, 2021
An update that solves one vulnerability and has three fixes is now available

Description

This update for postgresql13 fixes the following issues: - CVE-2021-3677: Fixed memory disclosure in certain queries (bsc#1189748). - Fixed build with llvm12 on s390x (bsc#1185952). - Re-enabled icu for PostgreSQL 10 (bsc#1179945). - Made the dependency of postgresqlXX-server-devel on llvm and clang optional (bsc#1187751). - llvm12 breaks PostgreSQL 11 and 12 on s390x. Use llvm11 as a workaround (bsc#1185952).

Patch

To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2021-3255=1

Package List

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libecpg6-13.4-5.16.2 libecpg6-debuginfo-13.4-5.16.2 libpq5-13.4-5.16.2 libpq5-debuginfo-13.4-5.16.2 postgresql13-13.4-5.16.2 postgresql13-contrib-13.4-5.16.2 postgresql13-contrib-debuginfo-13.4-5.16.2 postgresql13-debuginfo-13.4-5.16.2 postgresql13-debugsource-13.4-5.16.1 postgresql13-debugsource-13.4-5.16.2 postgresql13-devel-13.4-5.16.2 postgresql13-devel-debuginfo-13.4-5.16.2 postgresql13-llvmjit-13.4-5.16.2 postgresql13-llvmjit-debuginfo-13.4-5.16.2 postgresql13-plperl-13.4-5.16.2 postgresql13-plperl-debuginfo-13.4-5.16.2 postgresql13-plpython-13.4-5.16.2 postgresql13-plpython-debuginfo-13.4-5.16.2 postgresql13-pltcl-13.4-5.16.2 postgresql13-pltcl-debuginfo-13.4-5.16.2 postgresql13-server-13.4-5.16.2 postgresql13-server-debuginfo-13.4-5.16.2 postgresql13-server-devel-13.4-5.16.2 postgresql13-server-devel-debuginfo-13.4-5.16.2 postgresql13-test-13.4-5.16.2 - openSUSE Leap 15.3 (noarch): postgresql13-docs-13.4-5.16.2 - openSUSE Leap 15.3 (x86_64): libecpg6-32bit-13.4-5.16.2 libecpg6-32bit-debuginfo-13.4-5.16.2 libpq5-32bit-13.4-5.16.2 libpq5-32bit-debuginfo-13.4-5.16.2

References

https://www.suse.com/security/cve/CVE-2021-3677.html https://bugzilla.suse.com/1179945 https://bugzilla.suse.com/1185952 https://bugzilla.suse.com/1187751 https://bugzilla.suse.com/1189748

Severity
Announcement ID: openSUSE-SU-2021:3255-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 ble.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.