SUSE: 2022:2402-1 important: python-PyJWT

Advisories


   SUSE Security Update: Security update for python-PyJWT
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2402-1
Rating:             important
References:         #1199756 
Cross-References:   CVE-2022-29217
CVSS scores:
                    CVE-2022-29217 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
                    CVE-2022-29217 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Enterprise Storage 7
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3
                    SUSE Linux Enterprise Server 15-SP2-BCL
                    SUSE Linux Enterprise Server 15-SP2-LTSS
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP 15-SP2
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Linux Enterprise Storage 7.1
                    SUSE Manager Proxy 4.1
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.1
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.1
                    SUSE Manager Server 4.2
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-PyJWT fixes the following issues:

   - CVE-2022-29217: Fixed key confusion through non-blocklisted public key
     format (bsc#1199756).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2402=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-2402=1

   - SUSE Manager Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2402=1

   - SUSE Manager Retail Branch Server 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2402=1

   - SUSE Manager Proxy 4.1:

      zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2402=1

   - SUSE Linux Enterprise Server for SAP 15-SP2:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2402=1

   - SUSE Linux Enterprise Server 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2402=1

   - SUSE Linux Enterprise Server 15-SP2-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2402=1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-2402=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2402=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-2402=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2402=1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2402=1

   - SUSE Enterprise Storage 7:

      zypper in -t patch SUSE-Storage-7-2022-2402=1



Package List:

   - openSUSE Leap 15.4 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - openSUSE Leap 15.3 (noarch):

      python2-PyJWT-1.7.1-150200.3.3.1
      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Manager Server 4.1 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Manager Retail Branch Server 4.1 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Manager Proxy 4.1 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Server for SAP 15-SP2 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Server 15-SP2-LTSS (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Server 15-SP2-BCL (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (noarch):

      python2-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1

   - SUSE Enterprise Storage 7 (noarch):

      python3-PyJWT-1.7.1-150200.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-29217.html
   https://bugzilla.suse.com/1199756

SUSE: 2022:2402-1 important: python-PyJWT

July 14, 2022
An update that fixes one vulnerability is now available

Summary

This update for python-PyJWT fixes the following issues: - CVE-2022-29217: Fixed key confusion through non-blocklisted public key format (bsc#1199756). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2402=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-2402=1 - SUSE Manager Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-2402=1 - SUSE Manager Retail Branch Server 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-2402=1 - SUSE Manager Proxy 4.1: zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-2402=1 - SUSE Linux Enterprise Server for SAP 15-SP2: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-2402=1 - SUSE Linux Enterprise Server 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-2402=1 - SUSE Linux Enterprise Server 15-SP2-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-BCL-2022-2402=1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3: zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2022-2402=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2402=1 - SUSE Linux Enterprise Module for Basesystem 15-SP3: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-2402=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-2402=1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-2402=1 - SUSE Enterprise Storage 7: zypper in -t patch SUSE-Storage-7-2022-2402=1 Package List: - openSUSE Leap 15.4 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - openSUSE Leap 15.3 (noarch): python2-PyJWT-1.7.1-150200.3.3.1 python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Manager Server 4.1 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Manager Retail Branch Server 4.1 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Manager Proxy 4.1 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Server for SAP 15-SP2 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Server 15-SP2-LTSS (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Server 15-SP2-BCL (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (noarch): python2-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (noarch): python3-PyJWT-1.7.1-150200.3.3.1 - SUSE Enterprise Storage 7 (noarch): python3-PyJWT-1.7.1-150200.3.3.1

References

#1199756

Cross- CVE-2022-29217

CVSS scores:

CVE-2022-29217 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

CVE-2022-29217 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

SUSE Enterprise Storage 7

SUSE Linux Enterprise Desktop 15-SP3

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS

SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP3

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3

SUSE Linux Enterprise Server 15-SP2-BCL

SUSE Linux Enterprise Server 15-SP2-LTSS

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP 15-SP2

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Linux Enterprise Storage 7.1

SUSE Manager Proxy 4.1

SUSE Manager Proxy 4.2

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.1

SUSE Manager Retail Branch Server 4.2

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.1

SUSE Manager Server 4.2

SUSE Manager Server 4.3

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-29217.html

https://bugzilla.suse.com/1199756

Severity
Announcement ID: SUSE-SU-2022:2402-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.