SUSE: 2022:4022-1 moderate: ant | LinuxSecurity.com

   SUSE Security Update: Security update for ant
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4022-1
Rating:             moderate
References:         #1171696 #1177180 
Cross-References:   CVE-2020-11979 CVE-2020-1945
CVSS scores:
                    CVE-2020-11979 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
                    CVE-2020-11979 (SUSE): 4.9 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
                    CVE-2020-1945 (NVD) : 6.3 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
                    CVE-2020-1945 (SUSE): 4.9 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for ant fixes the following issues:

   - CVE-2020-1945: Fixed insecure temporary file vulnerability (bsc#1171696).
   - CVE-2020-11979: Fixed issue introduced with fix for CVE-2020-1945
     (bsc#1177180).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4022=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4022=1



Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch):

      ant-1.9.4-3.12.1
      ant-antlr-1.9.4-3.12.3
      ant-apache-bcel-1.9.4-3.12.3
      ant-apache-bsf-1.9.4-3.12.3
      ant-apache-log4j-1.9.4-3.12.3
      ant-apache-oro-1.9.4-3.12.3
      ant-apache-regexp-1.9.4-3.12.3
      ant-apache-resolver-1.9.4-3.12.3
      ant-commons-logging-1.9.4-3.12.3
      ant-javadoc-1.9.4-3.12.3
      ant-javamail-1.9.4-3.12.3
      ant-jdepend-1.9.4-3.12.3
      ant-jmf-1.9.4-3.12.1
      ant-junit-1.9.4-3.12.3
      ant-manual-1.9.4-3.12.3
      ant-scripts-1.9.4-3.12.1
      ant-swing-1.9.4-3.12.1

   - SUSE Linux Enterprise Server 12-SP5 (noarch):

      ant-1.9.4-3.12.1


References:

   https://www.suse.com/security/cve/CVE-2020-11979.html
   https://www.suse.com/security/cve/CVE-2020-1945.html
   https://bugzilla.suse.com/1171696
   https://bugzilla.suse.com/1177180

SUSE: 2022:4022-1 moderate: ant

November 16, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for ant fixes the following issues: - CVE-2020-1945: Fixed insecure temporary file vulnerability (bsc#1171696). - CVE-2020-11979: Fixed issue introduced with fix for CVE-2020-1945 (bsc#1177180). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4022=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4022=1 Package List: - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch): ant-1.9.4-3.12.1 ant-antlr-1.9.4-3.12.3 ant-apache-bcel-1.9.4-3.12.3 ant-apache-bsf-1.9.4-3.12.3 ant-apache-log4j-1.9.4-3.12.3 ant-apache-oro-1.9.4-3.12.3 ant-apache-regexp-1.9.4-3.12.3 ant-apache-resolver-1.9.4-3.12.3 ant-commons-logging-1.9.4-3.12.3 ant-javadoc-1.9.4-3.12.3 ant-javamail-1.9.4-3.12.3 ant-jdepend-1.9.4-3.12.3 ant-jmf-1.9.4-3.12.1 ant-junit-1.9.4-3.12.3 ant-manual-1.9.4-3.12.3 ant-scripts-1.9.4-3.12.1 ant-swing-1.9.4-3.12.1 - SUSE Linux Enterprise Server 12-SP5 (noarch): ant-1.9.4-3.12.1

References

#1171696 #1177180

Cross- CVE-2020-11979 CVE-2020-1945

CVSS scores:

CVE-2020-11979 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

CVE-2020-11979 (SUSE): 4.9 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

CVE-2020-1945 (NVD) : 6.3 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

CVE-2020-1945 (SUSE): 4.9 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

https://www.suse.com/security/cve/CVE-2020-11979.html

https://www.suse.com/security/cve/CVE-2020-1945.html

https://bugzilla.suse.com/1171696

https://bugzilla.suse.com/1177180

Severity
Announcement ID: SUSE-SU-2022:4022-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.