SUSE: 2022:4016-1 important: rubygem-nokogiri | LinuxSecurity.com

   SUSE Security Update: Security update for rubygem-nokogiri
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4016-1
Rating:             important
References:         #1198408 #1199782 
Cross-References:   CVE-2022-24836 CVE-2022-29181
CVSS scores:
                    CVE-2022-24836 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-24836 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-29181 (NVD) : 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
                    CVE-2022-29181 (SUSE): 7.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Basesystem 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for rubygem-nokogiri fixes the following issues:

   - CVE-2022-24836: Fixes possibility to DoS because of inefficient RE in
     HTML encoding. (bsc#1198408)
   - CVE-2022-29181: Fixes Improper Handling of Unexpected Data Typesi.
     (bsc#1199782)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-4016=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-4016=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      ruby2.5-rubygem-nokogiri-1.8.5-150400.14.3.1
      ruby2.5-rubygem-nokogiri-debuginfo-1.8.5-150400.14.3.1
      ruby2.5-rubygem-nokogiri-doc-1.8.5-150400.14.3.1
      ruby2.5-rubygem-nokogiri-testsuite-1.8.5-150400.14.3.1
      rubygem-nokogiri-debugsource-1.8.5-150400.14.3.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

      ruby2.5-rubygem-nokogiri-1.8.5-150400.14.3.1
      ruby2.5-rubygem-nokogiri-debuginfo-1.8.5-150400.14.3.1
      rubygem-nokogiri-debugsource-1.8.5-150400.14.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-24836.html
   https://www.suse.com/security/cve/CVE-2022-29181.html
   https://bugzilla.suse.com/1198408
   https://bugzilla.suse.com/1199782

SUSE: 2022:4016-1 important: rubygem-nokogiri

November 16, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for rubygem-nokogiri fixes the following issues: - CVE-2022-24836: Fixes possibility to DoS because of inefficient RE in HTML encoding. (bsc#1198408) - CVE-2022-29181: Fixes Improper Handling of Unexpected Data Typesi. (bsc#1199782) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-4016=1 - SUSE Linux Enterprise Module for Basesystem 15-SP4: zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-4016=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): ruby2.5-rubygem-nokogiri-1.8.5-150400.14.3.1 ruby2.5-rubygem-nokogiri-debuginfo-1.8.5-150400.14.3.1 ruby2.5-rubygem-nokogiri-doc-1.8.5-150400.14.3.1 ruby2.5-rubygem-nokogiri-testsuite-1.8.5-150400.14.3.1 rubygem-nokogiri-debugsource-1.8.5-150400.14.3.1 - SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64): ruby2.5-rubygem-nokogiri-1.8.5-150400.14.3.1 ruby2.5-rubygem-nokogiri-debuginfo-1.8.5-150400.14.3.1 rubygem-nokogiri-debugsource-1.8.5-150400.14.3.1

References

#1198408 #1199782

Cross- CVE-2022-24836 CVE-2022-29181

CVSS scores:

CVE-2022-24836 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2022-24836 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2022-29181 (NVD) : 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

CVE-2022-29181 (SUSE): 7.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Basesystem 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-24836.html

https://www.suse.com/security/cve/CVE-2022-29181.html

https://bugzilla.suse.com/1198408

https://bugzilla.suse.com/1199782

Severity
Announcement ID: SUSE-SU-2022:4016-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.