SUSE: 2022:4284-1 important: webkit2gtk3 | LinuxSecurity.com

   SUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4284-1
Rating:             important
References:         #1205120 #1205121 #1205122 #1205123 #1205124 
                    
Cross-References:   CVE-2022-32888 CVE-2022-32923 CVE-2022-42799
                    CVE-2022-42823 CVE-2022-42824
CVSS scores:
                    CVE-2022-32888 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32888 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32923 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
                    CVE-2022-32923 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
                    CVE-2022-42799 (NVD) : 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
                    CVE-2022-42799 (SUSE): 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
                    CVE-2022-42823 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-42823 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-42824 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
                    CVE-2022-42824 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE CaaS Platform 4.0
                    SUSE Enterprise Storage 6
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
                    SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise Server 15-SP1-BCL
                    SUSE Linux Enterprise Server 15-SP1-LTSS
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server for SAP 15-SP1
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:


   Security fixes:

   - CVE-2022-32888: Fixed possible arbitrary code execution via maliciously
     crafted web content (bsc#1205121).
   - CVE-2022-32923: Fixed possible information leak via maliciously crafted
     web content (bsc#1205122).
   - CVE-2022-42799: Fixed user interface spoofing when visiting a malicious
     website (bsc#1205123).
   - CVE-2022-42823: Fixed possible arbitrary code execution via maliciously
     crafted web content (bsc#1205120).
   - CVE-2022-42824: Fixed possible sensitive user information leak via
     maliciously crafted web content (bsc#1205124).

   Update to version 2.38.2:

     - Fix scrolling issues in some sites having fixed background.
     - Fix prolonged buffering during progressive live playback.
     - Fix the build with accessibility disabled.
     - Fix several crashes and rendering issues.

   Update to version 2.38.1:

     - Make xdg-dbus-proxy work if host session bus address is an abstract
       socket.
     - Use a single xdg-dbus-proxy process when sandbox is enabled.
     - Fix high resolution video playback due to unimplemented changeType
       operation.
     - Ensure GSubprocess uses posix_spawn() again and inherit file
       descriptors.
     - Fix player stucking in buffering (paused) state for progressive
       streaming.
     - Do not try to preconnect on link click when link preconnect setting is
       disabled.
     - Fix close status code returned when the client closes a WebSocket in
       some cases.
     - Fix media player duration calculation.
     - Fix several crashes and rendering issues.

   Update to version 2.38.0:

     - New media controls UI style.
     - Add new API to set WebView's Content-Security-Policy for web
       extensions support.
     - Make it possible to use the remote inspector from other browsers using
       WEBKIT_INSPECTOR_HTTP_SERVER env var.
     - MediaSession is enabled by default, allowing remote media control
       using MPRIS.
     - Add support for PDF documents using PDF.js.


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15-SP1:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-4284=1

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-4284=1

   - SUSE Linux Enterprise Server 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-4284=1

   - SUSE Linux Enterprise Server 15-SP1-BCL:

      zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-4284=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-4284=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-4284=1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-4284=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4284=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4284=1

   - SUSE Enterprise Storage 6:

      zypper in -t patch SUSE-Storage-6-2022-4284=1

   - SUSE CaaS Platform 4.0:

      To install this update, use the SUSE CaaS Platform 'skuba' tool. It
      will inform you if it detects new updates and let you then trigger
      updating of the complete cluster in a controlled way.



Package List:

   - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE Enterprise Storage 6 (aarch64 x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1

   - SUSE Enterprise Storage 6 (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE CaaS Platform 4.0 (noarch):

      libwebkit2gtk3-lang-2.38.2-150000.3.122.1

   - SUSE CaaS Platform 4.0 (x86_64):

      libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1
      libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1
      libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1
      typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1
      typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1
      webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1
      webkit2gtk3-debugsource-2.38.2-150000.3.122.1
      webkit2gtk3-devel-2.38.2-150000.3.122.1


References:

   https://www.suse.com/security/cve/CVE-2022-32888.html
   https://www.suse.com/security/cve/CVE-2022-32923.html
   https://www.suse.com/security/cve/CVE-2022-42799.html
   https://www.suse.com/security/cve/CVE-2022-42823.html
   https://www.suse.com/security/cve/CVE-2022-42824.html
   https://bugzilla.suse.com/1205120
   https://bugzilla.suse.com/1205121
   https://bugzilla.suse.com/1205122
   https://bugzilla.suse.com/1205123
   https://bugzilla.suse.com/1205124

SUSE: 2022:4284-1 important: webkit2gtk3

November 29, 2022
An update that fixes 5 vulnerabilities is now available

Summary

Security fixes: - CVE-2022-32888: Fixed possible arbitrary code execution via maliciously crafted web content (bsc#1205121). - CVE-2022-32923: Fixed possible information leak via maliciously crafted web content (bsc#1205122). - CVE-2022-42799: Fixed user interface spoofing when visiting a malicious website (bsc#1205123). - CVE-2022-42823: Fixed possible arbitrary code execution via maliciously crafted web content (bsc#1205120). - CVE-2022-42824: Fixed possible sensitive user information leak via maliciously crafted web content (bsc#1205124). Update to version 2.38.2: - Fix scrolling issues in some sites having fixed background. - Fix prolonged buffering during progressive live playback. - Fix the build with accessibility disabled. - Fix several crashes and rendering issues. Update to version 2.38.1: - Make xdg-dbus-proxy work if host session bus address is an abstract socket. - Use a single xdg-dbus-proxy process when sandbox is enabled. - Fix high resolution video playback due to unimplemented changeType operation. - Ensure GSubprocess uses posix_spawn() again and inherit file descriptors. - Fix player stucking in buffering (paused) state for progressive streaming. - Do not try to preconnect on link click when link preconnect setting is disabled. - Fix close status code returned when the client closes a WebSocket in some cases. - Fix media player duration calculation. - Fix several crashes and rendering issues. Update to version 2.38.0: - New media controls UI style. - Add new API to set WebView's Content-Security-Policy for web extensions support. - Make it possible to use the remote inspector from other browsers using WEBKIT_INSPECTOR_HTTP_SERVER env var. - MediaSession is enabled by default, allowing remote media control using MPRIS. - Add support for PDF documents using PDF.js. Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server for SAP 15-SP1: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-4284=1 - SUSE Linux Enterprise Server for SAP 15: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-4284=1 - SUSE Linux Enterprise Server 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-4284=1 - SUSE Linux Enterprise Server 15-SP1-BCL: zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-4284=1 - SUSE Linux Enterprise Server 15-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-2022-4284=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-4284=1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-4284=1 - SUSE Linux Enterprise High Performance Computing 15-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4284=1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-2022-4284=1 - SUSE Enterprise Storage 6: zypper in -t patch SUSE-Storage-6-2022-4284=1 - SUSE CaaS Platform 4.0: To install this update, use the SUSE CaaS Platform 'skuba' tool. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way. Package List: - SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server for SAP 15-SP1 (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server for SAP 15 (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-SP1-LTSS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-SP1-BCL (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-SP1-BCL (x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise Server 15-LTSS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE Enterprise Storage 6 (aarch64 x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1 - SUSE Enterprise Storage 6 (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE CaaS Platform 4.0 (noarch): libwebkit2gtk3-lang-2.38.2-150000.3.122.1 - SUSE CaaS Platform 4.0 (x86_64): libjavascriptcoregtk-4_0-18-2.38.2-150000.3.122.1 libjavascriptcoregtk-4_0-18-debuginfo-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-2.38.2-150000.3.122.1 libwebkit2gtk-4_0-37-debuginfo-2.38.2-150000.3.122.1 typelib-1_0-JavaScriptCore-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2-4_0-2.38.2-150000.3.122.1 typelib-1_0-WebKit2WebExtension-4_0-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-2.38.2-150000.3.122.1 webkit2gtk-4_0-injected-bundles-debuginfo-2.38.2-150000.3.122.1 webkit2gtk3-debugsource-2.38.2-150000.3.122.1 webkit2gtk3-devel-2.38.2-150000.3.122.1

References

#1205120 #1205121 #1205122 #1205123 #1205124

Cross- CVE-2022-32888 CVE-2022-32923 CVE-2022-42799

CVE-2022-42823 CVE-2022-42824

CVSS scores:

CVE-2022-32888 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32888 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32923 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-32923 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-42799 (NVD) : 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

CVE-2022-42799 (SUSE): 6.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

CVE-2022-42823 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-42823 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-42824 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

CVE-2022-42824 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Affected Products:

SUSE CaaS Platform 4.0

SUSE Enterprise Storage 6

SUSE Linux Enterprise High Performance Computing 15-ESPOS

SUSE Linux Enterprise High Performance Computing 15-LTSS

SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS

SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS

SUSE Linux Enterprise Server 15-LTSS

SUSE Linux Enterprise Server 15-SP1-BCL

SUSE Linux Enterprise Server 15-SP1-LTSS

SUSE Linux Enterprise Server for SAP 15

SUSE Linux Enterprise Server for SAP 15-SP1

https://www.suse.com/security/cve/CVE-2022-32888.html

https://www.suse.com/security/cve/CVE-2022-32923.html

https://www.suse.com/security/cve/CVE-2022-42799.html

https://www.suse.com/security/cve/CVE-2022-42823.html

https://www.suse.com/security/cve/CVE-2022-42824.html

https://bugzilla.suse.com/1205120

https://bugzilla.suse.com/1205121

https://bugzilla.suse.com/1205122

https://bugzilla.suse.com/1205123

https://bugzilla.suse.com/1205124

Severity
Announcement ID: SUSE-SU-2022:4284-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.