Arch Linux Security Advisory ASA-202101-17
==========================================

Severity: Critical
Date    : 2021-01-12
CVE-ID  : CVE-2020-16044
Package : thunderbird
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1440

Summary
=======

The package thunderbird before version 78.6.1-1 is vulnerable to
arbitrary code execution.

Resolution
==========

Upgrade to 78.6.1-1.

# pacman -Syu "thunderbird>=78.6.1-1"

The problem has been fixed upstream in version 78.6.1.

Workaround
==========

None.

Description
===========

A security issue was found in Firefox before 84.0.2 and Thunderbird
before 78.6.1-1. A malicious peer could have modified a COOKIE-ECHO
chunk in an SCTP packet in a way that potentially resulted in a use-
after-free. Mozilla presumes that with enough effort it could have been
exploited to run arbitrary code.

Impact
======

A malicious remote user could forge an SCTP packet and possibly execute
arbitrary code.

References
==========

https://www.mozilla.org/en-US/security/advisories/mfsa2021-02/
https://www.mozilla.org/en-US/security/advisories/mfsa2021-01/#CVE-2020-16044
https://bugzilla.mozilla.org/show_bug.cgi?id=1683964
https://hg.mozilla.org/mozilla-central/rev/08ba03dc8d4420e04e7c77fee3013e68180e6ead
https://hg.mozilla.org/mozilla-central/rev/8c09f4813fc7e8f44605b6092262199bff15cdd7
https://hg.mozilla.org/mozilla-central/rev/5991645a87d2abf289686d09d943229c9e3e54b5
https://security.archlinux.org/CVE-2020-16044