Arch Linux Security Advisory ASA-202103-12
==========================================

Severity: Low
Date    : 2021-03-25
CVE-ID  : CVE-2021-28831
Package : busybox
Type    : denial of service
Remote  : No
Link    : https://security.archlinux.org/AVG-1707

Summary
=======

The package busybox before version 1.32.1-4 is vulnerable to denial of
service.

Resolution
==========

Upgrade to 1.32.1-4.

# pacman -Syu "busybox>=1.32.1-4"

The problem has been fixed upstream but no release is available yet.

Workaround
==========

None.

Description
===========

decompress_gunzip.c in BusyBox through 1.32.1 mishandles the error bit
on the huft_build result pointer, with a resultant invalid free or
segmentation fault, via malformed gzip data.

Impact
======

A local attacker is able to provide a crafted zip file to crash the
application.

References
==========

https://bugs.archlinux.org/task/70075
https://git.busybox.net/busybox/commit/?id=f25d254dfd4243698c31a4f3153d4ac72aa9e9bd
https://security.archlinux.org/CVE-2021-28831