Arch Linux Security Advisory ASA-202103-13
==========================================

Severity: Critical
Date    : 2021-03-25
CVE-ID  : CVE-2021-22192
Package : gitlab
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1710

Summary
=======

The package gitlab before version 13.9.4-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 13.9.4-1.

# pacman -Syu "gitlab>=13.9.4-1"

The problem has been fixed upstream in version 13.9.4.

Workaround
==========

None.

Description
===========

An issue has been discovered in GitLab CE/EE affecting all versions
starting from 13.2 allowing unauthorized authenticated users to execute
arbitrary code on the server.

Impact
======

An authenticated malicious user is able to execute arbitrary code on
the affected server.

References
==========

https://about.gitlab.com/releases/2021/03/17/security-release-gitlab-13-9-4-released/#remote-code-execution-via-unsafe-user-controlled-markdown-rendering-options
https://hackerone.com/reports/1125425
https://gitlab.com/gitlab-org/gitlab/-/issues/324452
https://gitlab.com/gitlab-org/gitlab/-/commit/179329b5c3c118924fb242dc449d06b4ed6ccb66
https://security.archlinux.org/CVE-2021-22192