Discover Government News

Arch Linux Security Advisory ASA-201512-1
========================================
Severity: Critical
Date    : 2015-12-02
CVE-ID  : CVE-2015-6764 CVE-2015-6765 CVE-2015-6766 CVE-2015-6767
CVE-2015-6768 CVE-2015-6769 CVE-2015-6770 CVE-2015-6771 CVE-2015-6772
CVE-2015-6773 CVE-2015-6774 CVE-2015-6775 CVE-2015-6776 CVE-2015-6777
CVE-2015-6778 CVE-2015-6779 CVE-2015-6780 CVE-2015-6781 CVE-2015-6782
CVE-2015-6784 CVE-2015-6785 CVE-2015-6786 CVE-2015-6787
Package : chromium
Type    : multiple issues
Remote  : Yes
Link    : https://wiki.archlinux.org/title/CVE

Summary
======
The package chromium before version 47.0.2526.73-1 is vulnerable to
multiple issues including but not limited to various memory corruption,
cross-origin bypass and scheme bypass.

Resolution
=========
Upgrade to 47.0.2526.73-1.

# pacman -Syu "chromium>=47.0.2526.73-1"

The problem has been fixed upstream in version 47.0.2526.73.

Workaround
=========
None.

Description
==========
- CVE-2015-6764:

Out of bounds access in v8. Credit to Guang Gong of Qihoo 360 via pwn2own.

- CVE-2015-6765, CVE-2015-6766, CVE-2015-6767:

Use-after-free in AppCache.

- CVE-2015-6768, CVE-2015-6770, CVE-2015-6772:

Cross-origin bypass in DOM. Credit to Mariusz Mlynski.

- CVE-2015-6769:

Cross-origin bypass in core. Credit to Mariusz Mlynski.

- CVE-2015-6771:

Out of bounds access in v8.

- CVE-2015-6773:

Out of bounds access in Skia. Credit to cloudfuzzer.

- CVE-2015-6774:

Use-after-free in Extensions.

- CVE-2015-6775:

Type confusion in PDFium. Credit to Atte Kettunen of OUSPG.

- CVE-2015-6776:

Out of bounds access in PDFium. Credit to Hanno Böck.

- CVE-2015-6777:

Use-after-free in DOM. Credit to Long Liu of Qihoo 360Vulcan Team.

- CVE-2015-6778:

Out of bounds access in PDFium. Credit to Karl Skomski.

- CVE-2015-6779:

Scheme bypass in PDFium. Credit to Til Jasper Ullrich.

- CVE-2015-6780:

Use-after-free in Infobars. Credit to Khalil Zhani.

- CVE-2015-6781:

Integer overflow in Sfntly. Credit to miaubiz.

- CVE-2015-6782:

Content spoofing in Omnibox. Credit to Luan Herrera.

- CVE-2015-6784:

Escaping issue in saved pages. Credit to Inti De Ceukelaire.

- CVE-2015-6785:

Wildcard matching issue in CSP. Credit to Michael Ficarra / Shape Security.

- CVE-2015-6786:

Scheme bypass in CSP. Credit to Michael Ficarra / Shape Security.

- CVE-2015-6787:

Various fixes from internal audits, fuzzing and other initiatives.

Impact
=====
A remote attacker might be able to bypass CSP and cross-origin policies,
or execute arbitrary code on the affected host.

References
=========
https://chromereleases.googleblog.com/2015/12/stable-channel-update.html

ArchLinux: 201512-1: chromium: multiple issues

December 2, 2015

Summary

- CVE-2015-6764: Out of bounds access in v8. Credit to Guang Gong of Qihoo 360 via pwn2own.
- CVE-2015-6765, CVE-2015-6766, CVE-2015-6767:
Use-after-free in AppCache.
- CVE-2015-6768, CVE-2015-6770, CVE-2015-6772:
Cross-origin bypass in DOM. Credit to Mariusz Mlynski.
- CVE-2015-6769:
Cross-origin bypass in core. Credit to Mariusz Mlynski.
- CVE-2015-6771:
Out of bounds access in v8.
- CVE-2015-6773:
Out of bounds access in Skia. Credit to cloudfuzzer.
- CVE-2015-6774:
Use-after-free in Extensions.
- CVE-2015-6775:
Type confusion in PDFium. Credit to Atte Kettunen of OUSPG.
- CVE-2015-6776:
Out of bounds access in PDFium. Credit to Hanno Böck.
- CVE-2015-6777:
Use-after-free in DOM. Credit to Long Liu of Qihoo 360Vulcan Team.
- CVE-2015-6778:
Out of bounds access in PDFium. Credit to Karl Skomski.
- CVE-2015-6779:
Scheme bypass in PDFium. Credit to Til Jasper Ullrich.
- CVE-2015-6780:
Use-after-free in Infobars. Credit to Khalil Zhani.
- CVE-2015-6781:
Integer overflow in Sfntly. Credit to miaubiz.
- CVE-2015-6782:
Content spoofing in Omnibox. Credit to Luan Herrera.
- CVE-2015-6784:
Escaping issue in saved pages. Credit to Inti De Ceukelaire.
- CVE-2015-6785:
Wildcard matching issue in CSP. Credit to Michael Ficarra / Shape Security.
- CVE-2015-6786:
Scheme bypass in CSP. Credit to Michael Ficarra / Shape Security.
- CVE-2015-6787:
Various fixes from internal audits, fuzzing and other initiatives.

Resolution

Upgrade to 47.0.2526.73-1. # pacman -Syu "chromium>=47.0.2526.73-1"
The problem has been fixed upstream in version 47.0.2526.73.

References

https://chromereleases.googleblog.com/2015/12/stable-channel-update.html

Severity
CVE-2015-6768 CVE-2015-6769 CVE-2015-6770 CVE-2015-6771 CVE-2015-6772
CVE-2015-6773 CVE-2015-6774 CVE-2015-6775 CVE-2015-6776 CVE-2015-6777
CVE-2015-6778 CVE-2015-6779 CVE-2015-6780 CVE-2015-6781 CVE-2015-6782
CVE-2015-6784 CVE-2015-6785 CVE-2015-6786 CVE-2015-6787
Package : chromium
Type : multiple issues
Remote : Yes
Link : https://wiki.archlinux.org/title/CVE

Workaround

None.

Related News