Debian Linux Distribution

Find the information you need for your favorite open source distribution .

Arch Linux Security Advisory ASA-201703-11
=========================================
Severity: Critical
Date    : 2017-03-15
CVE-ID  : CVE-2017-2997 CVE-2017-2998 CVE-2017-2999 CVE-2017-3000
          CVE-2017-3001 CVE-2017-3002 CVE-2017-3003
Package : flashplugin
Type    : multiple issues
Remote  : Yes
Link    : https://security.archlinux.org/AVG-208

Summary
======
The package flashplugin before version 25.0.0.127-1 is vulnerable to
multiple issues including arbitrary code execution and information
disclosure.

Resolution
=========
Upgrade to 25.0.0.127-1.

# pacman -Syu "flashplugin>=25.0.0.127-1"

The problems have been fixed upstream in version 25.0.0.127.

Workaround
=========
None.

Description
==========
- CVE-2017-2997 (arbitrary code execution)

A buffer overflow vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

- CVE-2017-2998 (arbitrary code execution)

A memory corruption vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

- CVE-2017-2999 (arbitrary code execution)

A memory corruption vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

- CVE-2017-3000 (information disclosure)

A random number generator vulnerability used for constant blinding that
could lead to information disclosure has been found in Adobe Flash
Player <= 24.0.0.221.

- CVE-2017-3001 (arbitrary code execution)

A use-after-free vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

- CVE-2017-3002 (arbitrary code execution)

A use-after-free vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

- CVE-2017-3003 (arbitrary code execution)

A use-after-free vulnerability that could lead to code execution has
been found in Adobe Flash Player <= 24.0.0.221.

Impact
=====
A remote attacker can access sensitive information or execute arbitrary
code on the affected host.

References
=========
https://helpx.adobe.com/support/programs/support-options-free-discontinued-apps-services.html
https://security.archlinux.org/CVE-2017-2997
https://security.archlinux.org/CVE-2017-2998
https://security.archlinux.org/CVE-2017-2999
https://security.archlinux.org/CVE-2017-3000
https://security.archlinux.org/CVE-2017-3001
https://security.archlinux.org/CVE-2017-3002
https://security.archlinux.org/CVE-2017-3003

ArchLinux: 201703-11: flashplugin: multiple issues

March 15, 2017

Summary

- CVE-2017-2997 (arbitrary code execution) A buffer overflow vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-2998 (arbitrary code execution)
A memory corruption vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-2999 (arbitrary code execution)
A memory corruption vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-3000 (information disclosure)
A random number generator vulnerability used for constant blinding that could lead to information disclosure has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-3001 (arbitrary code execution)
A use-after-free vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-3002 (arbitrary code execution)
A use-after-free vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.
- CVE-2017-3003 (arbitrary code execution)
A use-after-free vulnerability that could lead to code execution has been found in Adobe Flash Player <= 24.0.0.221.

Resolution

Upgrade to 25.0.0.127-1. # pacman -Syu "flashplugin>=25.0.0.127-1"
The problems have been fixed upstream in version 25.0.0.127.

References

https://helpx.adobe.com/support/programs/support-options-free-discontinued-apps-services.html https://security.archlinux.org/CVE-2017-2997 https://security.archlinux.org/CVE-2017-2998 https://security.archlinux.org/CVE-2017-2999 https://security.archlinux.org/CVE-2017-3000 https://security.archlinux.org/CVE-2017-3001 https://security.archlinux.org/CVE-2017-3002 https://security.archlinux.org/CVE-2017-3003

Severity
CVE-2017-3001 CVE-2017-3002 CVE-2017-3003
Package : flashplugin
Type : multiple issues
Remote : Yes
Link : https://security.archlinux.org/AVG-208

Workaround

None.

Related News