Linux Security
    Linux Security
    Linux Security

    ArchLinux: 202010-3: linux-zen: multiple issues

    Date
    50
    Posted By
    The package linux-zen before version 5.9.1.zen2-1 is vulnerable to multiple issues including information disclosure, privilege escalation and denial of service.
    Arch Linux Security Advisory ASA-202010-3
    =========================================
    
    Severity: High
    Date    : 2020-10-18
    CVE-ID  : CVE-2020-12351 CVE-2020-12352 CVE-2020-24490
    Package : linux-zen
    Type    : multiple issues
    Remote  : Yes
    Link    : https://security.archlinux.org/AVG-1249
    
    Summary
    =======
    
    The package linux-zen before version 5.9.1.zen2-1 is vulnerable to
    multiple issues including information disclosure, privilege escalation
    and denial of service.
    
    Resolution
    ==========
    
    Upgrade to 5.9.1.zen2-1.
    
    # pacman -Syu "linux-zen>=5.9.1.zen2-1"
    
    The problems have been fixed upstream in version 5.9.1.zen2.
    
    Workaround
    ==========
    
    None.
    
    Description
    ===========
    
    - CVE-2020-12351 (privilege escalation)
    
    A flaw was found in the way the Linux kernel Bluetooth implementation
    handled L2CAP packets with A2MP CID. A remote attacker in adjacent
    range could use this flaw to crash the system causing denial of service
    or potentially execute arbitrary code on the system by sending a
    specially crafted L2CAP packet. The highest threat from this
    vulnerability is to data confidentiality and integrity as well as
    system availability.
    
    - CVE-2020-12352 (information disclosure)
    
    An information leak flaw was found in the way the Linux kernel's
    Bluetooth stack implementation handled initialization of stack memory
    when handling certain AMP packets. A remote attacker in adjacent range
    could use this flaw to leak small portions of stack memory on the
    system by sending a specially crafted AMP packets. The highest threat
    from this vulnerability is to data confidentiality.
    
    - CVE-2020-24490 (denial of service)
    
    A heap buffer overflow flaw was found in the way the Linux kernel’s
    Bluetooth implementation processed extended advertising report events.
    This flaw allows a remote attacker in an adjacent range to crash the
    system, causing a denial of service or to potentially execute arbitrary
    code on the system by sending a specially crafted Bluetooth packet. The
    highest threat from this vulnerability is to confidentiality,
    integrity, as well as system availability.
    
    Impact
    ======
    
    A remote unauthenticated attacker in range is able to execute arbitrary
    code, disclose information or DoS the system through bluetooth.
    
    References
    ==========
    
    https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00435.html
    https://github.com/google/security-research/security/advisories/GHSA-h637-c88j-47wq
    https://lore.kernel.org/linux-bluetooth/This email address is being protected from spambots. You need JavaScript enabled to view it./
    https://lore.kernel.org/linux-bluetooth/This email address is being protected from spambots. You need JavaScript enabled to view it./
    https://github.com/google/security-research/security/advisories/GHSA-7mh3-gq28-gfrq
    https://github.com/google/security-research/security/advisories/GHSA-ccx2-w2r4-x649
    https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=a2ec905d1e160a33b2e210e45ad30445ef26ce0e
    https://security.archlinux.org/CVE-2020-12351
    https://security.archlinux.org/CVE-2020-12352
    https://security.archlinux.org/CVE-2020-24490
    

    LinuxSecurity Poll

    I agree with Linus Torvalds - Apple's new M1-powered laptops should run on Linux.

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 2 answer(s).
    /main-polls/45-i-agree-with-linus-torvalds-apple-s-new-m1-powered-laptops-should-run-on-linux?task=poll.vote&format=json
    45
    radio
    [{"id":"158","title":"True","votes":"8","type":"x","order":"1","pct":100,"resources":[]},{"id":"159","title":"False","votes":"0","type":"x","order":"2","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350

    Please vote first in order to view vote results.


    VIEW MORE POLLS

    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.