Arch Linux Security Advisory ASA-202011-6
=========================================

Severity: Critical
Date    : 2020-11-10
CVE-ID  : CVE-2020-26950
Package : firefox
Type    : arbitrary code execution
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1265

Summary
=======

The package firefox before version 82.0.3-1 is vulnerable to arbitrary
code execution.

Resolution
==========

Upgrade to 82.0.3-1.

# pacman -Syu "firefox>=82.0.3-1"

The problem has been fixed upstream in version 82.0.3.

Workaround
==========

None.

Description
===========

A use-after-free has been found in Firefox before 82.0.3 where, in
certain circumstances, the MCallGetProperty opcode can be emitted with
unmet assumptions.

Impact
======

A remote attacker can execute arbitrary code on the affected host.

References
==========

https://www.mozilla.org/en-US/security/advisories/mfsa2020-49/
https://www.mozilla.org/en-US/security/advisories/mfsa2020-49/#CVE-2020-26950
https://bugzilla.mozilla.org/show_bug.cgi?id=1675905
https://security.archlinux.org/CVE-2020-26950