ArchLinux: 202106-14: ruby-bundler: insufficient validation | Linux...

Advisories

Arch Linux Security Advisory ASA-202106-14
==========================================

Severity: Medium
Date    : 2021-06-01
CVE-ID  : CVE-2020-36327
Package : ruby-bundler
Type    : insufficient validation
Remote  : Yes
Link    : https://security.archlinux.org/AVG-1891

Summary
=======

The package ruby-bundler before version 2.2.18-1 is vulnerable to
insufficient validation.

Resolution
==========

Upgrade to 2.2.18-1.

# pacman -Syu "ruby-bundler>=2.2.18-1"

The problem has been fixed upstream in version 2.2.18.

Workaround
==========

None.

Description
===========

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes
chooses a dependency source based on the highest gem version number,
which means that a rogue gem found at a public source may be chosen,
even if the intended choice was a private gem that is a dependency of
another private gem that is explicitly depended on by the application.

Impact
======

A remote attacker could replace a private gem in a project with a
public gem under their control with a higher version number.

References
==========

https://github.com/rubygems/rubygems/issues/3982
https://github.com/rubygems/rubygems/pull/4609
https://github.com/rubygems/rubygems/commit/d68d3cdb9cc69f648f87e5d3f25881677c1179ea
https://security.archlinux.org/CVE-2020-36327

ArchLinux: 202106-14: ruby-bundler: insufficient validation

June 3, 2021
The package ruby-bundler before version 2.2.18-1 is vulnerable to insufficient validation

Summary

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.

Resolution

Upgrade to 2.2.18-1.
# pacman -Syu "ruby-bundler>=2.2.18-1"
The problem has been fixed upstream in version 2.2.18.

References

https://github.com/rubygems/rubygems/issues/3982 https://github.com/rubygems/rubygems/pull/4609 https://github.com/rubygems/rubygems/commit/d68d3cdb9cc69f648f87e5d3f25881677c1179ea https://security.archlinux.org/CVE-2020-36327

Severity
CVE-ID : CVE-2020-36327
Package : ruby-bundler
Type : insufficient validation
Remote : Yes
Link : https://security.archlinux.org/AVG-1891

Impact

A remote attacker could replace a private gem in a project with a public gem under their control with a higher version number.

Workaround

None.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.